[From nobody Tue Oct 27 08:39:05 2026
Received: (at submit) by bugs.debian.org; 3 Feb 2024 20:14:02 +0000
X-Spam-Checker-Version: SpamAssassin 3.4.6-bugs.debian.org_2005_01_02
 (2021-04-09) on buxtehude.debian.org
X-Spam-Level: 
X-Spam-Status: No, score=-8.9 required=4.0 tests=BAYES_00, FOURLA,
 FROMDEVELOPER, 
 KHOP_HELO_FCRDNS,RDNS_DYNAMIC,SPF_HELO_NONE,SPF_NONE,
 T_SCC_BODY_TEXT_LINE,XMAILER_REPORTBUG autolearn=ham
 autolearn_force=no version=3.4.6-bugs.debian.org_2005_01_02
X-Spam-Bayes: score:0.0000 Tokens: new, 21; hammy, 149; neutral, 52; spammy,
 1. spammytokens:0.945-+--H*r:bugs.debian.org
 hammytokens:0.000-+--H*F:U*carnil, 0.000-+--XDebbugsCc,
 0.000-+--X-Debbugs-Cc, 0.000-+--H*M:reportbug, 0.000-+--H*MI:reportbug
Return-path: &lt;carnil@debian.org&gt;
Received: from c-82-192-242-114.customer.ggaweb.ch ([82.192.242.114]:50026
 helo=eldamar.lan) by buxtehude.debian.org with esmtp (Exim 4.94.2)
 (envelope-from &lt;carnil@debian.org&gt;) id 1rWMOm-001Ame-3j
 for submit@bugs.debian.org; Sat, 03 Feb 2024 20:14:02 +0000
Content-Type: text/plain; charset=&quot;us-ascii&quot;
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Salvatore Bonaccorso &lt;carnil@debian.org&gt;
To: Debian Bug Tracking System &lt;submit@bugs.debian.org&gt;
Subject: libowasp-antisamy-java: CVE-2024-23635
Message-ID: &lt;170699123914.3456759.3744197263564235566.reportbug@eldamar.lan&gt;
X-Mailer: reportbug 12.0.0
Date: Sat, 03 Feb 2024 21:13:59 +0100
Delivered-To: submit@bugs.debian.org

Source: libowasp-antisamy-java
Version: 1.7.4-1
Severity: important
Tags: security upstream
X-Debbugs-Cc: carnil@debian.org, Debian Security Team &lt;team@security.debian.org&gt;

Hi,

The following vulnerability was published for libowasp-antisamy-java.

CVE-2024-23635[0]:
| AntiSamy is a library for performing fast, configurable cleansing of
| HTML coming from untrusted sources. Prior to 1.7.5, there is a
| potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused
| by flawed parsing of the HTML being sanitized. To be subject to this
| vulnerability the `preserveComments` directive must be enabled in
| your policy file. As a result, certain crafty inputs can result in
| elements in comment tags being interpreted as executable when using
| AntiSamy's sanitized output. Patched in AntiSamy 1.7.5 and later.


If you fix the vulnerability please also make sure to include the
CVE (Common Vulnerabilities &amp; Exposures) id in your changelog entry.

For further information see:

[0] https://security-tracker.debian.org/tracker/CVE-2024-23635
    https://www.cve.org/CVERecord?id=CVE-2024-23635
[1] https://github.com/nahsra/antisamy/security/advisories/GHSA-2mrq-w8pv-5pvq

Please adjust the affected versions in the BTS as needed.

Regards,
Salvatore
]