[Aptitude-devel] Bug#671439: aptitude have unmet dependencies on libapt-pkg4.10 on alpha and other archs
baryluk at smp.if.uj.edu.pl
Fri May 4 03:48:01 UTC 2012
When trying to install aptitude I get:
a02:~# LC_ALL=C apt-get install aptitude -d
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
aptitude : Depends: libapt-pkg4.10 but it is not installable
Depends: libept1 but it is not going to be installed
Recommends: aptitude-doc-en but it is not going to be installed or
Recommends: libparse-debianchangelog-perl but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
This is because libapt-pkg4.12 is installed due new version of apt.
On other architectures aptitude have correct dependencies, but on alpha and few others,
it still depends on libapt-pkg4.10 which was actually virtually provided by apt.
Now with newer version of apt, libapt-pkg is separate real package,
and apt is depending on it. It also cannot be coinstalled with previous
versions (because it was virtual is one of the reasons).
I think aptitude should just depend on libapt-pkg4.12 probably.
Why alpha, hppa and this few other archs (most of them are unofficial ports) have
this separate depenency in first place?
a02:~# dpkg -l | grep apt
ii apt 0.9.2 commandline package manager
ii apt-utils 0.9.2 package managment related utility programs
ii libapt-inst1.5:alpha 0.9.2 deb package format runtime library
ii libapt-pkg4.12:alpha 0.9.2 package managment runtime library
a02:~# apt-cache show apt | grep 'Depends'
Depends: libapt-pkg4.12 (>= 0.8.16~exp9), libc6.1 (>= 2.4), libgcc1 (>= 1:4.1.1), libstdc++6 (>= 4.6), debian-archive-keyring, gnupg
a02:~# apt-cache show aptitude | grep 'Depends'
Depends: apt (>= 0.8.12), libapt-pkg4.10, libboost-iostreams1.48.0 (>= 1.48.0-1), libc6.1 (>= 2.4), libcwidget3, libept1, libgcc1 (>= 1:4.1.1), libncursesw5 (>= 5.6+20070908), libsigc++-2.0-0c2a (>= 2.0.2), libsqlite3-0 (>= 3.6.5), libstdc++6 (>= 4.6), libtinfo5, libxapian22, zlib1g (>= 1:1.1.4)
a02:~# LC_ALL=C apt-cache show libapt-pkg4.10
N: Can't select versions from package 'libapt-pkg4.10' as it is purely virtual
N: No packages found
-- System Information:
Debian Release: wheezy/sid
APT prefers unreleased
APT policy: (500, 'unreleased'), (500, 'unstable')
Kernel: Linux 3.2.0-1-alpha-generic
Locale: LANG=pl_PL.UTF-8, LC_CTYPE=pl_PL.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Versions of packages aptitude depends on:
ii apt 0.9.2
ii libapt-pkg4.10 <none>
ii libboost-iostreams1.48.0 <none>
ii libc6.1 2.13-27
ii libcwidget3 <none>
ii libept1 <none>
ii libgcc1 1:4.7.0-7
ii libncursesw5 5.9-7
ii libsigc++-2.0-0c2a 2.2.10-0.1
ii libsqlite3-0 3.7.11-3
ii libstdc++6 4.7.0-7
ii libtinfo5 5.9-7
ii libxapian22 1.2.8-1
ii zlib1g 1:1.2.6.dfsg-2
Versions of packages aptitude recommends:
ii apt-xapian-index 0.45
ii aptitude-doc-en | aptitude-doc <none>
ii libparse-debianchangelog-perl <none>
ii sensible-utils 0.0.6
Versions of packages aptitude suggests:
pn debtags <none>
pn tasksel <none>
More information about the Aptitude-devel