[Aptitude-devel] Bug#701946: aptitude: Internal error: no filename for <package>:amd64 after a failed install

Daniel Dickinson cshore at neomailbox.net
Sun Mar 3 03:04:26 UTC 2013

On 02/03/13 02:41 AM, Daniel Hartwig wrote:
> On 2 March 2013 09:57, Daniel Dickinson <cshore at neomailbox.net> wrote:
>> This happens with any of the packages I have tried to reinstall. For
>> example, if ccrypt is already installed, the emacs23 amd64 23.4+1-4 will
>> fail to install.  If you subsequently attempt a reinstall you will see
>> "E:  Internal error, No file name for emacs23:amd64".
> Is the issue with install, or reinstall?

Reinstall (that is using L in aptitude, after the install fails).

> Given that emacs23 will not “reinstall”, what is the output of:
> $ apt-cache policy emacs23:amd64

I'll send it if you want, but I'll have to create a new VM to create the
problem again because I worked around the problem by purging emacs23 and
installing it again.

I've had it happen three times on three separate VMs though, so I know I
can consistently get the error.



<erno> hm. I've lost a machine.. literally _lost_. it responds to ping,
it works completely, I just can't figure out where in my apartment it

More information about the Aptitude-devel mailing list