[Aptitude-devel] Unable to compile aptitude from git

berenger.morel at neutralite.org berenger.morel at neutralite.org
Thu Oct 31 00:35:48 GMT 2013

Le 31.10.2013 00:41, David Kalnischkies a écrit :
> Hi,
> On Wed, Oct 30, 2013 at 3:26 PM,  <berenger.morel at neutralite.org> 
> wrote:
>> Hello.
>> I am having a strange error when trying to compile aptitude from git 
>> repo:
>> When I do the ./configure, it ends with this error:
>> ===
>> checking the return type of boost::make_shared... configure: error:
>> in `/home/berenger/devel/aptitude':
>> configure: error: unknown
>> See `config.log' for more details
>> ===
>> The config.log does not contain any information that I understand
>> being related with that issue, but it is more than 2200 lines long, 
>> so
>> I did not really read it entirely.
>> I guess I miss a dependency, but I have no idea which one. Maybe it
>> could be a boost version error, too. Any idea?
>> PS: I have not found any list of dependencies for aptitude, so maybe
>> I lack a dependency which causes that error.
> As for every other package, ensure that you have a deb-src line in 
> your
> sources.list matching the deb line the package is coming from and 
> execute:
> apt-get build-dep aptitude
> It should install all needed packages to build the package from 
> source.

To be honest, I did not did it, for a more or less valid reason:
there were a lot of things needed, that I am not able to see why they 
should be needed. An example is elinks, a ncurse web browser ( and 
without development package concerning it ).
There were also things that aptitude does not seems to depends, when I 
look into what aptitude says about aptitude's dependencies, like 
python-dev (and I just checked anew, even in aptitude's dependencies 
there are no python dependency). But I do not know how build-dep works 
in it's internals, so I may be wrong anyway.

I already did some installation the same way as I did, and everything 
was fine. At least, I had some dependency errors, but was able to fix 
them easily by reading the output. Which does not work here.
I just installed the aptitude build-dep stuff, and have exactly the 
same result, still against the git repo.
Just did it the right way, by installing stuff aptitude says it depends 
on for building, and by using "apt-get -b source aptitude", and still 
the same error.

> As this is a aptitude specific question I would suggest following up 
> on
> aptitude-devel at lists.alioth.debian.org as they can probably help 
> better
> with more specific problems than deity@ can.

Sorry for that, I did not found it on the wiki page 
http://lists.debian.org/devel.html, where I thought I could find a more 
pertinent list. I'll send my mail anew there, and register on it.

I authorized myself to add my complete question before sending this 
mail, to cc it to the list you pointed me on.

Thanks for your reply.

More information about the Aptitude-devel mailing list