[Aptitude-devel] Bug#351239: aptitude: should re-fetch package list if gzip fails

Manuel A. Fernandez Montecelo manuel.montezelo at gmail.com
Mon Nov 16 19:55:06 UTC 2015

Control: tags -1 + moreinfo


2013-02-25 22:11 Axel Beckert:
>Control: tag -1 - moreinfo + confirmed
>Control: found -1
>Axel Beckert wrote:
>> > Now when I try to update the package list again, aptitude doesn't
>> > replace the Packages.gz that's already there (probably because it
>> > is up to date, and the download didn't abort with an error).
>> > Instead, it tries gzip again, which fails again.
>> I can't remember having had such an issue during the past few years
>> despite I encounter incomplete package list downloads occassionally.
>It doesn't seem to happen every time a download or uncompress fails,
>but I ran into this issue this weekend on Sid for three Package lists
>at the same time. It wasn't a gunzip fail though, but a BADSIG fail.
>The symptoms were the same, though.
>IIRC even "apt-get update" wasn't able to fix the issues either, so
>it's likely not an aptitude-specific issue. I though haven't found any
>according bug report against apt which sounds similar.
>I solved the issue finally by manually removing the according files
>from /var/lib/apt/lists/partial/.

If somebody runs into this and sees this bug report, please paste the
error so the problem is easier to pinpoint.

I suppose that this does not happen very often now with the pdiffs.

Manuel A. Fernandez Montecelo <manuel.montezelo at gmail.com>

More information about the Aptitude-devel mailing list