[Aptitude-devel] Bug#642800: show old and new dependencies on upgrade conflict

Manuel A. Fernandez Montecelo manuel.montezelo at gmail.com
Tue Nov 24 11:17:04 UTC 2015

Control: tags -1 + moreinfo

Hi Harald,

2011-09-25 06:54 Harald Dunkel:
>Hash: SHA1
>Package: aptitude
>Version: 0.6.4-1
>If there is a conflict on upgrade, then the bottom half
>window shows something like
>	package-a depends on package-b (>= 1.23)
>This is of little help, cause you do not know whether its
>the _old_ or the _new_ package-a. The "examine" window
>doesn't tell, either. You don't get a complete picture of
>the dependencies and why there is a problem.
>It would be very nice if the "examine" window could be

As an experiment, I tried to upgrade from systemd 227-2 to 228-2.  The
bottom window then said:

  systemd will be upgraded from version 227-2 to version 228-2.

  The following packages depend on version 227-2 of systemd, and will be
  broken if it is upgraded.
  * libpam-systemd depends on systemd (= 227-2)

Trying to upgrade uno-libs3:

  uno-libs3 will be upgraded from version 5.0.3~rc2-1+b1 to version
  The following packages depend on version 5.0.3~rc2-1+b1 of uno-libs3,
  and will be broken if it is upgraded.
  * ure depends on uno-libs3 (= 5.0.3~rc2-1+b1)

A package on which you just requested an action is upgraded, so other
packages's *planned* state (could be "just not upgraded", "remain on
hold", "upgrade") are broken as a consequence, because the current
action upsets the package's planned status.

Perhaps the situation could be improved by including the broken
package's version and planned action if possible, would that help?

If one presses "e" (for "examine") and goes to the ure package, the
bottom half shows:

  libpam-systemd depends upon systemd (= 227-2)
  --\ The following actions will resolve this dependency:
    -> Upgrade libpam-systemd [227-2 (now) -> 228-2 (unstable)]
    -> Remove libpam-systemd [227-2 (now)]
    -> Keep systemd at version 227-2 (now)
  ure depends upon uno-libs3 (= 5.0.3~rc2-1+b1)
  --\ The following actions will resolve this dependency:
    -> Upgrade ure [5.0.3~rc2-1+b1 (now) -> 5.1.0~alpha1-4 (experimental)]
    -> Upgrade ure [5.0.3~rc2-1+b1 (now) -> 5.0.3~rc2-1+b2 (unstable)]
    -> Remove ure [5.0.3~rc2-1+b1 (now)]
    -> Keep uno-libs3 at version 5.0.3~rc2-1+b1 (now)

>From this information one can see the version at which the package is
now, and which options could be taken (some of them will solve this
particular problem, but will break other things).

Same as above, perhaps including the current version (although it's
already printed in the solutions offered) and the current planned action
would help?  But otherwise I don't know how this could be improved.

Manuel A. Fernandez Montecelo <manuel.montezelo at gmail.com>

More information about the Aptitude-devel mailing list