[Aptitude-devel] Bug#800570: aptitude: Shows wrong short and long description for "Obsolete and Locally Created Packages" in TUI

Axel Beckert abe at debian.org
Thu Oct 1 00:47:10 UTC 2015

Control: severity -1 normal


Axel Beckert wrote:
> ---8<---
> 			 Packages                                       linux-image-4.1.0-trunk-amd64 info
> aptitude 0.7.2                                            Will free 170 MB of disk space
> ip       --\ linux-image-4.1.0-trunk-amd64      0  -170 MB   170 MB   4.1.2-1~exp1             <none>
>   Description: Perl module for merging hierarchies using the C3 algorithm

JFTR, after having purged the above shown package (as shown as already
schedule), the issue vanished. And I can't reproduce it with the
generated state bundle either. :-/ Lowering the severity hence.

One thing I can imagine is that I ran into it because I ran "aptitude
-u" and then later couldn't reproduce it with "aptitude" or
"aptitude-run-state-bundle", because the state bundle just caught the
files, not the state of the running process which possibly has updated
/var/lib/dpkg/status. So maybe the internal state and the state inside
/var/lib/dpkg/status has diverged by an offset of just a few packages?

		Regards, Axel
 ,''`.  |  Axel Beckert <abe at debian.org>, http://people.debian.org/~abe/
: :' :  |  Debian Developer, ftp.ch.debian.org Admin
`. `'   |  4096R: 2517 B724 C5F6 CA99 5329  6E61 2FF9 CD59 6126 16B5
  `-    |  1024D: F067 EA27 26B9 C3FC 1486  202E C09E 1D89 9593 0EDE

More information about the Aptitude-devel mailing list