[Aptitude-devel] Bug#802648: Bug#802648: aptitude: definite loop when searching "youk" in "youtube-dl" package info page

Axel Beckert abe at debian.org
Thu Oct 22 11:23:12 UTC 2015

Control: tag -1 + confimred - unreproducible


Axel Beckert wrote:
> > > 5. press "/", and enter "you", everything is OK for now
> > > 6. enter "k", the definite loop occures
> > 
> > JFTR: I can't reproduce this with 0.7.2-1 from Debian Testing (in the
> > big terminal). Will test Sid later.
> Tried it on Debian Sid amd64 with a 157x21 terminal. But nothing
> crashed, continues to work fine.

Sorry, I think I misunderstood the description initially. I
interpreted 'enter "you"' as typing the letters "y", "o", "u", and
then pressing the enter key and the pressing "k" to get one line up.

But if you enter "youk" aptitude no more reacts except on Ctrl-C. At
least once in the 157x21 terminal. But I wasn't able to reproduce it
even in the 157x21 terminal after I tried it in the same process while
the terminal was bigger.

So it may depend on what has already been done (and hence maybe cached
internally) before.

I was not able to reproduce it in 0.7.2-1 from testing at all, even
if I followed the instructions inside a freshly started aptitude in a
157x21 terminal.

		Regards, Axel
 ,''`.  |  Axel Beckert <abe at debian.org>, http://people.debian.org/~abe/
: :' :  |  Debian Developer, ftp.ch.debian.org Admin
`. `'   |  4096R: 2517 B724 C5F6 CA99 5329  6E61 2FF9 CD59 6126 16B5
  `-    |  1024D: F067 EA27 26B9 C3FC 1486  202E C09E 1D89 9593 0EDE

More information about the Aptitude-devel mailing list