[Aptitude-devel] Bug#802943: aptitude: Small problems printing information about conflicts and virtual packages

Manuel A. Fernandez Montecelo manuel.montezelo at gmail.com
Sun Oct 25 14:31:44 UTC 2015

Control: tags -1 + pending

2015-10-25 12:51 Manuel A. Fernandez Montecelo:
>Package: aptitude
>Version: 0.7.4-1
>Severity: minor
>>From bug #799918 (opening a new one to avoid all of the noise in that bug
>  jidanni:
>  OK now full-upgrade prints "- libgdal1i, but 1.11.3+dfsg-1~exp1 is to be
>  installed." twice! On the same line too.
>  (Note I always use the CLI aptitude and never curses.)
>    qgis : Depends: libgdal.so.1-1.11.2 which is a virtual package, provided by:
>                     - libgdal1i, but 1.11.3+dfsg-1~exp1 is to be installed.                  - libgdal1i, but 1.11.3+dfsg-1~exp1 is to be installed.
>		   The following actions will resolve these dependencies:
>     Remove the following packages:
>     1)     qgis
>In this case it looks like libgdal1i versions older than 1.11.3+dfsg-1~exp1
>provided libgdal.so.1-1.11.2, while the newer does not.
>Printing versions of the package providing the virtual package would inform
>better of the situation, and as a consequence it would make easier to find out /
>explain the reasons to have the conflicts/broken dependencies (and as a side
>effect, maybe avoid bugs reported as if it was a problem in aptitude rather than
>in packaging or transitions).
>Also, when printing twice (if they are several versions providing the virtual
>package), should do it in two lines rather than one, have nice formatting,
>perhaps not a dot in the end, etc.

Pushed fix, marking as +pending.

Manuel A. Fernandez Montecelo <manuel.montezelo at gmail.com>

More information about the Aptitude-devel mailing list