[Aptitude-devel] Bug#802648: Bug#802648: aptitude: definite loop when searching "youk" in "youtube-dl" package info page

Manuel A. Fernandez Montecelo manuel.montezelo at gmail.com
Mon Oct 26 10:33:29 UTC 2015

Control: found -1 aptitude/0.6.11

Hi all,

2015-10-22 12:23 Axel Beckert:
>Control: tag -1 + confimred - unreproducible
>Axel Beckert wrote:
>> > > 5. press "/", and enter "you", everything is OK for now
>> > > 6. enter "k", the definite loop occures
>> >
>> > JFTR: I can't reproduce this with 0.7.2-1 from Debian Testing (in the
>> > big terminal). Will test Sid later.
>> Tried it on Debian Sid amd64 with a 157x21 terminal. But nothing
>> crashed, continues to work fine.
>Sorry, I think I misunderstood the description initially. I
>interpreted 'enter "you"' as typing the letters "y", "o", "u", and
>then pressing the enter key and the pressing "k" to get one line up.
>But if you enter "youk" aptitude no more reacts except on Ctrl-C. At
>least once in the 157x21 terminal. But I wasn't able to reproduce it
>even in the 157x21 terminal after I tried it in the same process while
>the terminal was bigger.
>So it may depend on what has already been done (and hence maybe cached
>internally) before.
>I was not able to reproduce it in 0.7.2-1 from testing at all, even
>if I followed the instructions inside a freshly started aptitude in a
>157x21 terminal.

I can reproduce it all the time, also in 0.6.11 from stable (Jessie).

I think that it's partly due to the incremental search feature
(according to the backtrace), feature about which there are more
complaints in the BTS (but I haven't checked if they are related or

Manuel A. Fernandez Montecelo <manuel.montezelo at gmail.com>

More information about the Aptitude-devel mailing list