[Aptitude-devel] Bug#838560: aptitude: "aptitude -u" hangs indefinitely at "Loading cache" if an APT repo results in a 404 (maybe APT 1.3 related)

Andreas Schneider schneider.andi at gmail.com
Sun Oct 2 19:51:58 UTC 2016


I ran into the same symptom - aptitude stuck at "Loading cache" after
`aptitude -u` - after I had added the line
deb http://snapshot.debian.org/archive/debian/20160924/ sid main
non-free contrib
into sources.list. What revealed the root cause in my case was running
`apt-get update`, which produced the error message:
E: Release file for
is expired (invalid since 1d 21h 41min 22s). Updates for this
repository will not be applied.
This is known behavior and running aptitude as `aptitude -o
Acquire::Check-Valid-Until=false -u` suppresses the error and aptitude
works as normal.
What seems to be common between your setup and mine is that an error
during the update of the package lists isn't handled (anymore; this
worked previously) and that causes trouble later.



More information about the Aptitude-devel mailing list