[Aptitude-devel] Bug#867006: Bug#866974: Patch fixing 'Assertion "resman->resolver_exists()" failed.'

Axel Beckert abe at debian.org
Sun Sep 20 04:32:19 BST 2020

Hi again,

Axel Beckert wrote:
> Ahzo wrote:
> > the failure can be reliably reproduced with both the CLI (fatal
> > exception) and the TUI (assertion failure) in a minimal chroot
> Thanks for that! This makes it way easier to analyse this. Worked
> fine.

... on the commandline with "aptitude upgrade". Couldn't reproduce the
issue reported in the TUI.

Calling just "aptitude" (or "aptitude -u") and then pressing Shift-U
quickly finds a solution: Remove test-b and upgrade test-a.

Interestingly it even finds a solution if I mark test-b as hold and in
the "never automatically remove" list. It nevertheless removes it
despite "Allow dependency resolutions that break holds or forbids" is
not set.

But this seems an aptitude-internal issue: Exiting aptitude and
starting again no more removes test-b.

Still no error message though with that example.

> > Attached is a patch which fixes the problem by removing two checks
> > for !TargetVer() in the resolver code responsible for examining
> > Provides.
> Thanks even more for that! :-)
> Will test this

It definitely solves the resolver crash ("ERROR: search aborted by
fatal exception.") on "aptitude upgrade".

And since your patch explicitly mentions the other issue, I assume it
fixes that as well even if the example to reproduce this issues wasn't
perfect and only allowed me to reproduce one of these issues. (Or we
fixed the other one in earlier releases with an unexpected side
effect. :-)

Will nevertheless apply it and let it fix both bug reports.

Thanks again!

		Regards, Axel
 ,''`.  |  Axel Beckert <abe at debian.org>, https://people.debian.org/~abe/
: :' :  |  Debian Developer, ftp.ch.debian.org Admin
`. `'   |  4096R: 2517 B724 C5F6 CA99 5329  6E61 2FF9 CD59 6126 16B5
  `-    |  1024D: F067 EA27 26B9 C3FC 1486  202E C09E 1D89 9593 0EDE

More information about the Aptitude-devel mailing list