[Babel-users] openwrt babel configuration

Dane Medic dm70dm at gmail.com
Mon Jul 27 18:55:10 UTC 2015


Hi everybody!

I would like to ask you for some help regarding configuring babeld on 2
openwrt routers.
The 1st router (named GW) is doing NAT, 2nd router (named 2ND) has firewall
"disabled".
Wan port from 2ND (which is running dhcp client) is connected to Lan port
of GW (which is serving dhcp).
Each router has also connection to his client and I would like to be able
share data between clients and all devices should have internet conection.

Openwrt version is CC 15.05 - RC3 revision 46163 and I have downloaded and
installed
babeld_1.6.1-1_ar71xx.ipk package.

On the GW I change the following:

uci del network.lan.type
uci set network.lan.ipaddr=192.168.3.1
uci commit network

uci del babeld. at interface[0].ignore
uci set babeld. at interface[0].ifname=eth0.1 ## the Lan interface
uci add babeld filter
uci set babeld. at filter[2].type=redistribute
uci set babeld. at filter[2].ip=0.0.0.0/0
uci set babeld. at filter[2].action=allow
uci commit babeld

uci set system. at system[0].hostname=GW
uci commit system
----------------------

On the 2ND I change:

echo "config defaults
        option input ACCEPT
        option output ACCEPT
        option forward ACCEPT" > /etc/config/firewall

uci del network.lan.type
uci set network.lan.ipaddr=192.168.4.1
uci set network.wan.defaultroute=0
uci commit network

uci del babeld. at interface[0].ignore
uci set babeld. at interface[0].ifname=eth0.1 ## the Lan interface
uci del babeld. at interface[1].ignore
uci set babeld. at interface[1].ifname=eth1 ## the Wan interface
uci add babeld filter
uci set babeld. at filter[2].type=redistribute
uci set babeld. at filter[2].ip=192.168.4.0/24
uci set babeld. at filter[2].action=allow
uci commit babeld

uci set system. at system[0].hostname=2ND
uci commit system
----------------------

root at GW:~# ip route
192.168.3.0/24 dev eth0.1  proto kernel  scope link  src 192.168.3.1
192.168.3.135 via 192.168.3.135 dev eth0.1  proto babel onlink
192.168.4.0/24 via 192.168.3.135 dev eth0.1  proto babel onlink
192.168.4.1 via 192.168.3.135 dev eth0.1  proto babel onlink
----------------------

root at 2ND:~# ip route
192.168.3.0/24 dev eth1  proto kernel  scope link  src 192.168.3.135
192.168.3.1 dev eth1  proto static  scope link  src 192.168.3.135
192.168.4.0/24 dev eth0.1  proto kernel  scope link  src 192.168.4.1


I currently dont have Wan port connected anywhere on GW router at the
moment, is this why I cant see 0.0.0.0/0 on 2ND?

Is this configuration OK?

Thank you in advance and Regards
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/babel-users/attachments/20150727/6b51aa59/attachment.html>


More information about the Babel-users mailing list