[Babel-users] Study about Babel

Juliusz Chroboczek jch at irif.fr
Thu Feb 28 17:37:26 GMT 2019


> For BATMAN, I’m using LibreMesh.org and for BABEL, I’m trying to find a
> solution using OpenWRT and babeld but it is not a success… Does anybody know
> where I can find a simple solution using Babel protocol to implement on my
> routers with OpenWRT (or something similar)? 

It is my opinion that third-party firmwares are a bad idea -- if something
is worth sharing with the community, it should be included in OpenWRT
itself.  Babeld works just fine with stock OpenWRT.

On your OpenWRT box, create a statically configured interface in ad-hoc
mode.  In /etc/config/wireless:

  config wifi-iface 'wlan0'
      option device 'radio0'
      option mode 'adhoc'
      option ssid 'babel'
      option channel 11
      option encryption 'none'

In /etc/config/network: remove the interface from the 'lan' bridge (in
case it's included), then do:

  config interface 'wlan0'
      option ifname 'wlan0'
      option proto 'static'
      option ipaddr '192.168.2.1'
      option netmask '255.255.255.255'

You may add an IPv6 address if you wish.

In /etc/config/firewall, add the new interface to the 'lan' zone (since
you're no longer bridging it with the lan interface).

Then do

   opkg update
   opkg install babeld

and add the following to your /etc/config/babeld:

   config interface
       option ifname wlan0

   config filter
       option type redistribute
       option ip '0.0.0.0/0'
       option eq 0
       option action 'metric 128'

Feel free to write to the list again if you need any further help.

-- Juliusz





More information about the Babel-users mailing list