[Debian-l10n-devel] Bug#883014: poedit: Problems to use keyboard in Poedit textboxes, with Debian stable and KDE Plasma desktop

Laura Arjona Reina larjona at debian.org
Tue Nov 28 19:08:47 UTC 2017

Package: poedit
Version: 1.8.11-3
Severity: normal

Dear Maintainer,

   * What led up to the situation?

I'm using Debian 9 stable and KDE Plasma desktop (not sure if this is related, but maybe it's just that I'm missing a package).

   * What exactly did you do (or not do) that was effective (or

I installed Poedit and tried to work with some PO files.

   * What was the outcome of this action?

I found out that I cannot properly use the keyboard for editing the translating texts, and also have some issues in other text boxes (e.g. in Edit > preferences, editing my name).
It seems that I can add text, but cursors and backspace don't work. This makes editing a pain and the program almost un-usable :(
I found out that if I press backspace, change focus to other window, and return to Poedit, the key worked. But pressing several times does not work, only one key at a time (changing focus and returning to poedit between keystroke and keystroke).

   * What outcome did you expect instead?

I invoked Poedit from the command line and was expecting some error message when having the issue, but it didn't show any message.
I've tried to change the GTK themes in my desktop systemsettings (from Breeze to Adwaita) but didn't change anything.
I've installed Poedit from testing in my stable machine and the problem persists.
I'm a bit clueless in how to diagnose this. I've searched the internet and upstream issue tracker and couldn't find anything related.

*** End of the template - remove these template lines **
-- System Information:
Debian Release: 9.2
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-4-amd64 (SMP w/4 CPU cores)
Locale: LANG=es_ES.UTF-8, LC_CTYPE=es_ES.UTF-8 (charmap=UTF-8), LANGUAGE= (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages poedit depends on:
ii  gettext         
ii  libboost-iostreams1.62.0  1.62.0+dfsg-4
ii  libboost-system1.62.0     1.62.0+dfsg-4
ii  libc6                     2.24-11+deb9u1
ii  libcld2-0                 0.0.0-git20150806-5
ii  libcpprest2.9             2.9.1-1
ii  libdb5.3++                5.3.28-12+deb9u1
ii  libexpat1                 2.2.0-2+deb9u1
ii  libgcc1                   1:6.3.0-18
ii  libglib2.0-0              2.50.3-2
ii  libgtk2.0-0               2.24.31-2
ii  libgtkspell0              2.0.16-1.1
ii  libicu57                  57.1-6
ii  liblucene++0v5            3.0.7-8+b2
ii  libsecret-1-0             0.18.5-3.1
ii  libssl1.1                 1.1.0f-3+deb9u1
ii  libstdc++6                6.3.0-18
ii  libwxbase3.0-0v5          3.0.2+dfsg-4
ii  libwxgtk3.0-0v5           3.0.2+dfsg-4
ii  poedit-common             1.8.11-3

poedit recommends no packages.

poedit suggests no packages.

-- no debconf information

More information about the Debian-l10n-devel mailing list