[Debian-med-packaging] Bug#522021: [Help] Bug#522021: building arb fails on at least 64bit archs with missleading error message

Andreas Tille tillea at rki.de
Mon Apr 20 11:34:27 UTC 2009

[for debian-amd64 people please have a look at [1] ]


as Frank Lichtenheld suggested [1] I tried a patch which add's the -fPIC
option but please see below that it does not work even for for amd64.  So
I expect a general 64 bit problem but have no idea how to solve this.
Despite the fact that Florian Lohoff assumes that it might be a mips only
problem[2] the fact that we have to face the same on amd64 lets me assume
that we have some more general trouble and thus I also put debian-amd64
in CC and hope that anybody might have a clue how to fix this.

Kind regards


[1] http://bugs.debian.org/522021#15
[2] http://lists.debian.org/debian-mips/2009/03/msg00071.html


---------- Forwarded message ----------
Date: Mon, 20 Apr 2009 12:23:40 +0200
From: Dr. Martin Pfannkuchen <pfannkuchen at cim.irb.hr>
Reply-To: arb_users at yahoogroups.com
To: arb_users at yahoogroups.com
Subject: Re: ARB-64-bit

Dear Andreas,

here is the bad news: I included your patch and the make seems to terminate
with the same error, even though the -fPIC is now included into the g++ call.

Make everything in WINDOW
make[1]: Entering directory `/home/arb/arb-0.0.20071207.1/WINDOW'
g++ -fmessage-length=0 -Wall -shared -DNO_REGEXPR -DGNU -fPIC -o libAW.so
AW_position.o AW_Xm.o AW_at.o AW_button.o AW_click.o AW_device.o
AW_font_group.o AW_global_awars.o AW_nawar.o AW_preset.o AW_print.o
AW_question.o AW_size.o AW_status.o AW_window.o AW_xfig.o AW_xfigfont.o
AW_xfont.o AW_xkey.o GLwMDrawA.o GLwDrawA.o
/usr/bin/ld: GLwMDrawA.o: relocation R_X86_64_32 against `a local symbol' can
not be used when making a shared object; recompile with -fPIC
GLwMDrawA.o: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[1]: *** [libAW.a] Error 1
make[1]: Leaving directory `/home/arb/arb-0.0.20071207.1/WINDOW'
make: *** [WINDOW/libAW.dummy] Error 2

I included the -fPIC also in the g++ variable definition in line 105 of the
Makefile (GPP=g++ -fmessage-length=0 --> GPP=g++ -fPIC -fmessage-length=0) but
that did result in the same error message.
So I am still trying to find out, what the error actually means, but so far I
am unsuccessful in that. (Please donţ just exclude the amd64 architecture)



On Monday 20 April 2009 10:39:47 Andreas Tille wrote:
> On Sat, 18 Apr 2009, Dr. Martin Pfannkuchen wrote:
> > I looked through the
> > configuration and the Makefile as such and have the impression, that the
> > -fPIC is already set. (I attached the two files from the extracted arb
> > source package). Could you give me a hint on where else the -fPIC should
> > be set, or maybe also provide a patch?
> You are right that -fPIC is set for the compilation process but the advise
> to use -fPIC is issued when linking the dynamic library. So if you try
> --- arb-0.0.20071207.1.orig/Makefile
> +++ arb-0.0.20071207.1/Makefile
> @@ -207,7 +207,7 @@
> f77_flags = $(fflags) -W -N9 -e
> F77LIB = -lU77
> - ARCPPLIB = $(GPP) -Wall -shared $(LINUX_SPECIALS) -o
> + ARCPPLIB = $(GPP) -Wall -shared $(LINUX_SPECIALS) -fPIC -o
> ARLIB = $(GCC) -Wall -shared $(LINUX_SPECIALS) -o
> GMAKE = make -j 3 -r
> SYSLIBS = -lm
> the option will be set also in this case. When doing so the package
> continues to build fine on i386. I'm keen on hearing what happens on your
> amd64 machine.
> Kind regards
> Andreas.

Dr. Martin Pfannkuchen
Center for marine research Centar za istraživanje mora
Institut Ruder Boskovic Institut Ruđer Bošković
Giordano Paliaga 5 Giordano Paliaga 5
52210 Rovinj 52210 Rovinj
Croatia Hrvatska

Tel: + 385 52 804 736 email: pfannkuchen at cim.irb.hr
Fax: + 385 52 813 496 www.cim.irb.hr

More information about the Debian-med-packaging mailing list