[Debian-med-packaging] Bug#542656: prompting due to modified conffiles which where not modified by the user

Andreas Tille andreas at an3as.eu
Thu Aug 20 20:52:19 UTC 2009

On Thu, Aug 20, 2009 at 07:24:04PM +0200, Holger Levsen wrote:
> during a test with piuparts I noticed your package failed the piuparts upgrade 

Thanks foryou rpiuparts efforts - I hope to find the time to run
theses tests myself on at least my packages.

> ...
> Depends: adduser, debconf (>= 0.5) | debconf-2.0, menu, blends-common (>= 0.6.0)
> ...
>   Reading state information...
>   The following packages were automatically installed and are no longer required:
>     libgc1c2
>   Use 'apt-get autoremove' to remove them.
>   The following extra packages will be installed:
>     adduser cdd-common menu
> ...
>   WARNING: The following packages cannot be authenticated!
>     adduser menu cdd-common med-config
>   Authentication warning overridden.
>   Get:1 http://piatti.debian.org lenny/main adduser 3.110 [184kB]
>   Get:2 http://piatti.debian.org lenny/main menu 2.1.41 [453kB]
>   Get:3 http://piatti.debian.org lenny/main cdd-common 0.5.6 [19.6kB]
>   Get:4 http://piatti.debian.org lenny/main med-config 1.0 [9296B]

Considering this I wonder whether I can do the piuparts step by step
by creating a clean Lenny chroot and afterwards trying to upgrade to
the Squeeze versions.  Or is there any other way to do the piuparts
steps in "debug mode"?

BTW, is this a bug in the chroot creating code?  I also observed this
nuisance in my chroot since some point in time. :-(

>   Selecting previously deselected package blends-common.
>   Unpacking blends-common (from .../blends-common_0.6.3_all.deb) ...
>   sed: warning: failed to get security context of ./med.conf: Operation not supportedPreparing to replace cdd-common 0.5.6 (using .../cdd-common_0.6.3_all.deb) ...

Huh, any explanation for this "failed to get security context"?
Is this a SElinux issue? Never seen this warning from sed.

>   Unpacking replacement med-config ...
>   dpkg: warning: unable to delete old directory '/etc/cdd/med': Directory not empty
>   dpkg: warning: unable to delete old directory '/etc/cdd': Directory not empty
>   Processing triggers for menu ...
>   Setting up mawk (1.3.3-15) ...
>   Setting up gcc-4.3-base (4.3.3-14) ...
>   Setting up libdb4.6 (4.6.21-14) ...
>   Setting up libgc1c2 (1:6.8-1.2) ...
>   Setting up blends-common (0.6.3) ...
>   Setting up cdd-common (0.6.3) ...
Hmmm, could you please do me a favour and run the test against a recent version
(=0.6.5) whihch just entered testing which is actually fixing an upgrade problem
(see #540603).  It might be that the problem is just fixed (even if I have
spotted a potential further problem in the logs).

Thanks again for testing


Klarmachen zum Ändern!

More information about the Debian-med-packaging mailing list