Bug#588861: python-openturns: uninstallable in testing: Depends: python (< 2.6) but 2.6.5-5 is to be installed

Jakub Wilk jwilk at debian.org
Mon Jul 12 20:49:31 UTC 2010

Package: python-openturns
Version: 0.13.2-2
Severity: serious
Tags: squeeze
User: debian-python at lists.debian.org
Usertag: python2.6


python-openturns is currently uninstallable in testing:

# apt-get install python-openturns
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
   python-openturns: Depends: python (< 2.6) but 2.6.5-5 is to be installed
E: Broken packages

We would normally fix this bug by simply binNMUing the package. However, 
openturns FTBFS in testing because of bug #586351:

openturns 0.13.2-5 (which has #586351 fixed and binaries recompiled with 
Python 2.6) cannot migrate to testing because of dependencies on atlas, 
which cannot be satisfied on armel. We tried to get rid of these 
dependencies by binNMUing it against liblapack-dev >= 3.2.2-1, but 
openturns failed to build:
We have no idea what's the reason of this FTBFS, as we were unable to 
reproduce it on the porterbox.

Jakub Wilk
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/debian-science-maintainers/attachments/20100712/b9da2d95/attachment.pgp>

More information about the debian-science-maintainers mailing list