[xml/sgml-pkgs] Bug#251511: libxml-dev: conflict on libxml2-dev too strict

Aaron M. Ucko "Aaron M. Ucko" <ucko@debian.org>, 251511@bugs.debian.org
Fri, 28 May 2004 16:30:10 -0400

Package: libxml-dev
Version: 1:1.8.17-6
Severity: important
Tags: sid

libxml-dev specifies "Conflicts: libxml2-dev (< 2.6.10-2)".  However,
"<" is a deprecated synonym for "<=", and probably not what you want
(since 2.6.10-2 is okay); "<<" should have the right semantics.  (See
Policy 7.1.)

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.4.26
Locale: LANG=en_US, LC_CTYPE=en_US

Versions of packages libxml-dev depends on:
ii  libxml1                      1:1.8.17-5  GNOME XML library
ii  zlib1g-dev [libz-dev]        1: compression library - development

-- no debconf information