[xml/sgml-pkgs] Bug#293828: python2.3-libxslt1: shouldn't have versioned dependency on dummy libxml2-python2.3

Ivan Nestlerode Ivan Nestlerode <nestler@speakeasy.net>, 293828@bugs.debian.org
Sat, 05 Feb 2005 21:04:22 -0500

Package: python2.3-libxslt1
Version: 1.1.12-4
Severity: normal

The python bindings for libxml2 and libxslt1 just had their packages renamed.
I attempted to remove the old dummy packages
(libxml2-python2.3 and libxslt1-python2.3), but I cannot do so because
python2.3-libxslt1 has a versioned dependency on libxml2-python2.3 (the
dummy package):

Package: python2.3-libxslt1
Depends: libxml2-python2.3 (>= 2.6.15)

python2.3-libxml2 provides libxml2-python2.3 but I do not think you can
do a versioned "Provides:" to satisfy this versioned dependency.

My first guess for a fix is to change this dependency to be on
python2.3-libxml2 (to avoid depending on the dummy layer, avoiding the issue of versioned "Provides:"), but I'm not sure if that would affect the smoothness of
the upgrade transition.


-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.10
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages python2.3-libxslt1 depends on:
ii  libc6                    2.3.2.ds1-20    GNU C Library: Shared libraries an
ii  libxml2-python2.3        2.6.16-2        Python 2.3 bindings for the GNOME 
ii  libxslt1.1               1.1.12-4        XSLT processing library - runtime 
ii  python2.3                2.3.4+2.3.5c1-2 An interactive high-level object-o
ii  python2.3-libxml2 [libxm 2.6.16-2        Python 2.3 bindings for the GNOME 

-- no debconf information