[Filesystems-devel] Bug#844205: aufs-dkms: I can't load the kernel module after upgrade from Jessie to Stretch.

Leo hachreak at gmail.com
Sun Nov 13 10:50:48 UTC 2016

Package: aufs-dkms
Version: 4.8+20161010-1
Severity: critical
Tags: d-i
Justification: causes serious data loss

Dear Maintainer,

   * What led up to the situation?

I wanted to upgrade from Jessie to Stretch.

   * What exactly did you do (or not do) that was effective (or

I run apt-get dist-upgrade. Everything was working (or at least, no
critical error appeared).
After that, docker stop to work because the aufs kernel module was not
I tried to install the aufs packages but the kernel can't find it (maybe
because my kernel is 4.7?).

   * What was the outcome of this action?

The only way to have docker working is to delete all the old
It means that I'm losing all my data inside.

   * What outcome did you expect instead?

To load the module correctly and have docker working again also with
images/containers stored
with aufs.
Or, at least to be able to migrate my old images/containers from aufs to
another storage service.

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.7.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages aufs-dkms depends on:
ii  dkms  2.3-1

Versions of packages aufs-dkms recommends:
ii  aufs-tools  1:4.1+20161010-1

Versions of packages aufs-dkms suggests:
ii  aufs-dev  4.8+20161010-1

-- no debconf information
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/filesystems-devel/attachments/20161113/4a8641a9/attachment.html>

More information about the Filesystems-devel mailing list