[Freedombox-discuss] quick notes from freedom-maker install today..

Markus Sabadello markus at projectdanube.org
Fri Apr 4 15:18:57 UTC 2014


Just tried it today and thought I'd post a few notes..
I'm going with the "boot from USB, then copy to MicroSD" option

1. freedom-maker itself ran without problems, yay, I love how it's now
using Petter's deb package.

2. When booting from USB, my devices are different from what's in the
README. I have pretty much always had this problem, every single time
I tried it. So when I boot from USB, I have to pass root=/dev/sda2
instead of root=/dev/sdc2

3. When booting for the first time, I get this:

/dev/sda2: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.                                                    
        (i.e., without -a or -p options)                                                                   
fsck died with exit status 4                                                                               
failed (code 4).                                                                                           

Then I do a manual fsck /dev/sda2, and I get this:

[....] Checking root file system...fsck from util-linux 2.20.1                                             
/dev/sda2: Superblock last mount time (Fri Apr  4 08:37:30 2014,                                           
        now = Thu Mar 27 09:43:11 2014) is in the future.                                                  

So this doesn't seem to be a real problem, just a timestamp thing.
After this, booting from USB works fine.

4. I find the first-run process a bit fragile, sometimes the network
just isn't available on first boot.
But thankfully it's easy to just recreate
/var/lib/freedombox/first-run-enable and run again.
I believe a while ago this was harder, since the first-run script got
deleted entirely 

5. When doing copy2dream, my devices are messed up again.
I have to replace all "sda" with "sdb" in copy2dream, because sda is
now my USB, and sdb is my MicroSD.
Otherwise copy2dream works fine.

6. I have to manually edit /etc/fstab on the MicroSD now, because the
UUIDs don't work.
This is mentioned correctly in the README.

7. Finally, I still have to manually fix my MAC addresses in
/etc/network/interfaces, not sure if this is supposed to work by now.

8. Then I can boot and everything works, I can access Plinth!
I'll play with the various functions a bit more in the next few days and
then maybe send some more notes.

Anyway, great work everyone on this 0.2, this is motivating.

And now the BONUS QUESTION: Where was the following picture taken????

all the best,

More information about the Freedombox-discuss mailing list