[Freedombox-discuss] Switch to btrfs on the Freedombox?

leen leen at consolejunkie.net
Mon Nov 24 07:17:51 UTC 2014

On 11/19/2014 11:43 AM, Petter Reinholdtsen wrote:
> [Leen]
>> Hi Peter,
> Hi. :)
> (Peter is my fifth cousin. :)

Oops, I'm really sorry.

>> Let me first say I think it's awesome what you are doing.
> Thank you.
>> People working with btrfs is very useful. I've been following btrfs
>> mailinglist on and off to see if I can use it for some kind of
>> production use.
> Glad to have you on board.  I do not follow the btrfs mailing list, only
> test it once in a while. :)
>> But let me point out that these errors can still occur:
>> "And btrfs can automatically allocate data and metadata chunks on demand
>> -- the catch is that it can't automatically unallocate
>> chunks on demand[1], a balance is required for that"
>> [1] Yet.  There's patches circulating that once thru discussion and
>> merged, should let btrfs automatically handle at least the normal cases
>> of data/metadata chunk imbalance.
>> http://thread.gmane.org/gmane.comp.file-systems.btrfs/39800/focus=39943
> Sad to hear that.  Is there any way we can work around it on the
> FreedomBox side?
> I hope we can get btrfs (or zfs) working out of the box with FreedomBox.
> But if not, we can drop the '--roottype btrfs' from the vmdebootstrap
> argument list and be back where we started.  The change is at least at
> the moment not intrucive.  It will be intrusive if we start to use
> snapshots and volume management, but we are not there yet.

It looks like the OpenSuse guys are now happy shipping it as the default:


My favorite test-case for btrfs which hasn't consistently worked yet:

Do a balance on a 2 disk RAID-1 btrfs root filesystem.

With Grub installed on both disk.

Shutdown the machine, pull a disk.

Start it up trying to mount with -o degraded (or kernel rootflags=).

Yesterday I tried this with this new OpenSuse release, but I couldn't
see if it worked. systemd or maybe dracut was in the way and I didn't
get any output or a prompt to investigate to see what is going on.

Even with debug on.

But I'll give it an other try soon on a system I do understand/know

I've recently learned adding recovery might help too so I hope I can
test that.

More information about the Freedombox-discuss mailing list