[Freedombox-discuss] Hackathon SFLC Halloween - pandodev comments on initial user experience

Carlos Cortes pandodev at gmail.com
Sat Oct 31 21:25:05 UTC 2015


I attended the Hackathon today, and it was the first time that I was coming
into contact with FreedomBox in a meaningful way. I ran FreedomBox on
Virtualbox from the distributed image (trivial) and experimented with the
UI as a new user. I have included my notes on the experience below in the
that some rough edges may be identified as opportunities for improvement. It
was a pleasure getting the opportunity to meet other members of the
community and dev team.



Observations related to initial installation

1. virtio kernel panic on virtualbox

Kernel Panic when using network adapter type 'virtio' on VirtualBox

2. VBox Guest Additions

VBox guest additions installation fails because freedombox doesn't have X
installed. Might want to make a mention of this on VBox install page since
is so commonly used.

3. nmap command in documentation

The nmap command from doc didn't work for finding IP of freedombox since the
SFLC office doesn't use 192.168.x.x. Did the appropriate thing for the
actually in use (10.5.53.x), but perhaps that section of the doc could be
expanded to figure out more effectively the IP of the machine.


Experience on First Login to FreedomBox

Feedback on the initial user experience.. this is all based on signing in
the first time and investigating the various applications that can be

0. Self-signed certificate Warning

First time you access FreedomBox you get certificate warning from Firefox.
self-signed cert) Documentation doesn't make any comment about this being ok
or not, which may scare some users.

1. Minor Typo: evertime -> every time


Your ISP does not provide you a static IP address and your IP address
evertime you connect to Internet.

2. Guiding user to next action on PageKite page

There are various tabs on this page:
- About PageKite
- Configure PageKite
- Standard Services
- Custom Services

.. as well as the button 'Configure PageKite'. However, clicking any of
results in the same message being displayed to user: "Install PageKite
packages" (approx). It would be better perhaps if there was a single button
install without any other superfluous items. That would guide the user to
next step.

3. Install Shaarli results in hanging UI, no feedback

Clicked on 'Install' button for Shaarli, and then decided to go click some
other links. The interface doesn't respond, and appears to be hanging. If
reload the 'Install' page, you don't get any feedback on what is actually
happening. Not very good from user experience perspective. Some feedback on
what is happening would be helpful. It did eventually come back quite a

4. Error when installing Dynamic DNS

Clicking install resulted in the following error:

Error installing packages: E: http://httpredir.debian.org sid/main amd64
Packages is not (yet) available ()

I then went to terminal and explicitly did a 'apt-get install ez-ipupdate'
that worked. Purged the package and went back to the interface, and clicked
'Install' button again. It worked. Don't know why.

5. http://freedombox.local doesn't work after initial setup

I was able to successfully access the mDNS address for plinth on the first
attempt when I was required to provide a username & password for main
login. When I tried to use that address again following that step so that I
could log in for the first time, I could not reach freedombox.local. I
around this by determining IP from CLI and then accessing the web interface

6. PageKite App activation

The 'pagekite' app activation page should tell you that you must sign up
separately for the service. Some people might not realize this.

It might not be obvious to folks that 'Kite Secret' and "pagekite.net
password" are not the same thing. Not realizing this resulted in some wasted

It would be helpful if some information from the logs could be presented in
order to help the user determine why an error occurred. The pagekite log
contained information on 'authentication failed' but that was not exposed on
the web page.

Is it required that you create a sub-kite, or should the root kite work? The
connection only seemed to occur successfully for a sub-kite. Meaning:
foo.pagekite.me doesn't work, but bar-foo.pagekite.me works.

7. Dynamic DNS Activation/Configuration

Created an account on afraid.org and proceeded to configure Dynamic DNS
app. The configuration files that were written to /etc/ez-ipupdate/ did not
seem to have correct data and how to debug this was quite not
obvious. Admittedly, I didn't dig deep into plinth code for this, but I'm
sure whether that's what you expect normal users to do.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/freedombox-discuss/attachments/20151031/65676d93/attachment.html>

More information about the Freedombox-discuss mailing list