[Freedombox-discuss] Setting up a FreedomBox on an apu1d4. Usb device (phone/modem) not seen by plinth.

A. F. Cano afc at shibaya.lonestar.org
Sat Apr 30 20:32:11 UTC 2016

On Tue, Apr 26, 2016 at 11:58:18PM -0400, A. F. Cano wrote:
> On Tue, Feb 16, 2016 at 11:41:37PM +0530, Sunil Mohan Adapa wrote:
> > ...
> > 2) When you connect a USB tethered phone it will show us as an Ethernet
> > device.  Which you can configure as 'external' connection in Plinth.  If

Earlier I said:

> Mmm... No such luck.  The only interfaces visible to plinth are the 3
> usual ones: one internal connected to the internal network (enp3s0),
> one internal not connected (enp2s0) and the WAM interface connected to
> the ubiquiti router.  More below.

After more more trial and error, I got a little further.

I can get the ppp connection started:

$ /sbin/route
Kernel IP routing table
Destination     Gateway  Genmask         Flags Metric Ref    Use Iface
default         U     0      0        0  ppp0
80.sub-66-174-1 UH    0      0        0  ppp0   U     100    0        0  enp3s0

I can do apt updates/upgrades from the command line (via ssh)

$ sudo apt update && sudo apt upgrade   # this works

This is with the tethered phone connected directly to the freedombox'x
usb port, not via a proxy on another local machine like I described

Per the online manual in the wiki, I tried to make the network manager
aware of the new connection:

$ sudo nmcli con add con-name "ppp" ifname "ppp0" type cdma
$ sudo nmcli con modify "ppp" connection.zone external

and the "Networks" page presented by plinth now has the "ppp" connection
listed, but it's inactive.  Clicking the "Activate" button has no
effect.  It says "Activated connection ppp" but the button never turns
green.  Tried this before and after deactivating the "Freedombox WAN"
interface, in case there is a limitation of only one external interface.

After de-activating the Freedombox WAN interface:

$ nmcli connection
NAME                   UUID                                  TYPE            DEVICE 
FreedomBox LAN enp3s0  a8e95667-240c-48bb-98be-0ee4a97c1fc2  802-3-ethernet  enp3s0 
FreedomBox LAN enp2s0  a7aaf4a1-a558-4cac-9f9e-a7a078492efb  802-3-ethernet  --     
FreedomBox WAN         51461052-3d5d-4261-8b49-727dd11b6c6b  802-3-ethernet  --     
ppp                    f2cc6f30-1726-42c2-b580-3ac8a98a21ec  cdma            --     

$ nmcli device
 DEVICE   TYPE      STATE         CONNECTION            
 enp3s0   ethernet  connected     FreedomBox LAN enp3s0 
 ttyACM0  cdma      disconnected  --                    
 enp1s0   ethernet  disconnected  --                    
 enp2s0   ethernet  unavailable   --                    
 lo       loopback  unmanaged     --                    
 ppp0     unknown   unmanaged     --   

Looks like I have some confusion as to what the network manager uses to
identify what it deals with.  Why are both ttyACM0 and ppp0 listed under
"DEVICE"?  Is there a way to associate "ttyACM0" with ppp0 under nmcli?
Is this necessary?

No surprise then that anything else is not working from the web

> > your phone only provides PPP, you will have configure that from 'nmtui'
> > from command line (Plinth does not do PPP connections yet)

Even with the ppp connection up and running, nmtui only sees the 3
ethernet connections.
> ...

Any ideas out there?

More information about the Freedombox-discuss mailing list