[Freedombox-discuss] Joining a mesh network with BATMAN

Bastien Rocheron b at kuma.la
Mon Nov 21 00:18:43 UTC 2016

Hello again,

Something very strange happened. As I was logged in through SSH trying
to understand this issue, suddenly my user was not recognized any more
and I received a message close to something like: user 1000 unknown, who
are you?

Then I logged out from ssh, tried to login again but was unable. The web
interface disappeared as well. That lasted for long enough that I gave
up trying.

After an hour or two I tried again and was greeted again by the web
interface. The weird thing is that it had changed. I had noticed that I
did not have the 'Disks' module in the menu and now it is there.
So I tried immediately to create a new network interface and now the web
interface accepts the channel and BSSID settings.

I am really curious as to what happened. It is great that things get
solved by itself but at the same time I fear automation is out of control.

Now I have followed the guide again and successfully created the first
interface for ad-hoc wireless and I can see on my router that this
interface is connected. But the bat0 interface did not get created in
the process and the second step is thus not possible.

I have done a lsmod and realized that no batman module was loaded. So I
first checked with modprobe that it can be loaded. Then I added
batman-adv in my /etc/modules-load.d/modules.conf and rebooted.
I now have batman_adv loaded along with its dependencies.
But trying again from scratch does not bring up bat0.

If no suggestion is made I will try to bring it up manually. But I guess
this will conflict with network manager. I need to understand how it is


On 20/11/16 17:59, Bastien Rocheron wrote:
> Hello,
> I am trying to join an existing mesh network (I have created it and have
> already various nodes in it) with freedombox.
> I am following the instructions found in the manual, specifically
> Joining a mesh network.
> The issue is that various settings are not available in the interface
> while adding a network connection(I'm using the latest image).
> For example I can't set the channel nor BSSID, without which, nodes
> can't join the network (as far as I'm aware).
> And thus in the next step I can't locate bat0 as an interface.
> Do you have any recommendations?
> Cheers.
> _______________________________________________
> Freedombox-discuss mailing list
> Freedombox-discuss at lists.alioth.debian.org
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/freedombox-discuss

More information about the Freedombox-discuss mailing list