[Freedombox-discuss] Plinth development, can't get past the login window.

A. F. Cano afc at shibaya.lonestar.org
Sun Apr 9 19:29:17 UTC 2017

I've set up 2 development systems with Debian Stretch, the first in a VM
and the second on real hardware.  In both cases I can't get past the login

In addition to the dependencies listed in the INSTALL file, more are needed.
I have already reported that firewalld in needed. I also encountered an
additonal error: missing Python.h, so I had to install libpython3.5-dev and

On the virtual machine I got as far as the "first boot"
screen where it asks you to set up the admin user and password.  At
first I thought I made a mistake typing the password because I could
never again log in.  But I now have encountered the same problem on the
real HW machine.  It might be a good idea to force the user to re-type
the password to catch typos, even though it appears that a typo is not the

On the VM I had done a

sudo python3 setup.py install

and I've been wondering ever since where, oh where? python and/or plinth
store the marker that tells it never to go back to that first boot screen
ever again.  I did wipe out everything (rm -rf Plinth) and did a fresh git
clone but this was not enough.  I still couldn't get back that first boot
screen to change the password.  I think this is still a valid question even
though I've recently found that you can get to the first boot screen by
going to http:/localhost:8000/plinth/firstboot/welcome/.

I also have a related question: why does this process (setup.py instal) and

sudo python3 setup.py develop

have to go out on the internet and download tar files from python.org with
extremely long links of random characters?  Are the packages that come with
the distribution not enough and/or complete? or is python.org just
keeping track of everyone that uses python code? I presume the code
being downloaded has been checked by the community.

Then, on the real hardware machine (not a VM) I upgraded a Jessie system to

Got the first boot screen, typed the user and password and immediately got

"Please enter a correct username and password.  Note that both fields may
be case-sensitive."

Any further re-typing of user name and password results in the same error.
I can never log in.

Tried explicitely to go to:

http:/localhost:8000/plinth/firstboot/welcome/ and I could get the user name
and password screen but with the same result: immediate error message and I
can never log in again.  On the real hardware system I made sure to do the
fewest possible operations.  Just:

sudo python3 setup.py develop
sudo ./run --debug

to limit possible side-effects.

I tried this with both konqueror and firefox.  Same result.

Does anyone have any suggestions? I have some new code to test but I can't get
through the very first step: the login window.  Of course this problem is with
totally stock plinth 13.1 code as it came from the git clone command.



More information about the Freedombox-discuss mailing list