[Freedombox-discuss] Can't get android phone to connect to radicale.

A. F. Cano afc at shibaya.lonestar.org
Sun Feb 5 02:11:34 UTC 2017

On Sat, Feb 04, 2017 at 02:30:58PM -0500, James Valleroy wrote:
> On 02/04/2017 01:52 PM, A. F. Cano wrote:
> > =================== Android log ====================
> >...
> > 2017-01-28 20:33:55 2 [ui.setup.DavResourceFinder] Checking user-given URL:<user>/
> > 2017-01-28 20:33:55 2 [HttpClient$1] --> PROPFIND<user>/ http/1.1
> > ...
> > This is what Davdroid says:
> > 
> > Configuration detection
> > 
> > Couldn't find CalDAV or CardDAV service.
> There shouldn't be any changes needed for the firewall.

Keep in mind that this is the firewall that's on the phone.

> What are you using for the Base URL in Davdroid? I just tried

The one above:<user>/

> https://<local IP address> and that worked.

I just tried that (with and without trailing /).  It didn't work.
Also tried:

https://<local IP address>/radicale (with and without trailing /)
https://<local IP address>/radicale/<user> (with and without trailing /)
https://<external>.freedombox.rocks (with and without trailing /)
https://<external>.freedombox.rocks/radicale (with and without trailing /)

The ones with freedombox.rocks took longer to return the error, so I'm
wondering if those requests went out on the internet (or the tor
network - orbot is running on the phone, but tor is not activated on
the freedombox).  In any case, they all failed.

> James

Thanks for replying.  I'm not too familiar with Android and compared to
the tools I have with linux, it's quite cumbersome to debug.  Any other
suggestions? Anyone?


More information about the Freedombox-discuss mailing list