[Freedombox-discuss] Guidance needed to add a new "connection" form for ppp.

A. F. Cano afc at shibaya.lonestar.org
Sun Feb 19 20:20:32 UTC 2017

Since I can't find a way to salvage the old unbootable SD card, I
installed freedombox-testing-free_2017-02-02_all-amd64.img on a new
32GB SD card.  Plugged it into a PC Engines apu1d4.

It was a nice surprise to find the option to expand the FS, but given the
recent thread about that option not working I tried it with trepidation.
It didn't work in the way described in that thread.

I notice that there is still no option to create an interface of type cdma
(for ppp).  Rather than using nmcli like I did the first time, I would like
to set up an additional menu entry and form to enter what minimal data is
needed.  That way, the interface will be properly known to plinth and fully

I believe the only options that need to be set explicitely are:

nmcli con add con-name "ppp" type cdma  # set by the connection type menu entry
nmcli con modify "ppp" connection.zone external # can be set automatically?
nmcli con modify "ppp" cdma.username qnc	# qnc can possibly be a default
nmcli con modify "ppp" cdma.password qnc	# but should be changeable

Other options (such as the phone number (#777) have good default values
for the cdma type.

Can someone point me to either documentation on how to do that or
where the existing forms are so I can use them as examples?

Since the ppp connection is (in my case) not permanent and on a usb port,
there might be an issue with the default route.  In the previous incarnation
(set up with nmcli) I had to disable the default route that pointed to the
WAN connection.  The WAN connection is active but the wifi router connected
to it is not associated with any network at the moment.  Would this be handled
automatically by plinth or network manager/modem manager?  I think assigning
the ppp connection a higher priority than the regular WAN connection would
do the trick.

Finally, a few observations:

Last I heard someone was working on porting shaarli to the current php.
That was the first application I tried and I really miss it.  Any idea when
it might be available again?

Without a working WAN connection, in order to do upgrades I had to create
/etc/apt/apt.conf to contain

Acquire::http::Proxy "http://192.168.x.y:8118/";

(privoxy on an internal machine already connected to the internet).

It was nice to see that this also worked to install the snapshots app.

About snapshots (but also applicable to backups) it would be nice if there
were an option to save the snapshots to another local machine on the internal
network.  That way, the old state could be recovered in cases such as what I
just went through, where the FreedomBox became unbootable and inaccessible and
the only option was to make a whole new SD card image.

A huge thank you to all the developers!


More information about the Freedombox-discuss mailing list