[Freedombox-discuss] Power on failure

Randy Griffiths rgriff35 at gmail.com
Thu Apr 26 04:06:31 BST 2018

Thanks for the tips. I tried several things tonight with no luck at first,
then mysteriously made some progress.dy I had tried plugging in a monitor
via the hdmi port but didn't see anything. I noticed when I ejected the SD
card the ethernet port lights came on.  Then I took the lime2 out of the
metal case and tried plugging in the power cord without the ethernet cable
but with the monitor and then I could see the freedombox boot up on the
screen and get to the login. I plugged the ethernet cord in and was able to
see the freedombox from the router. Hallelujah!

But when I try to access the freedombox from a browser through
freedombox.local I get the following error:

The server is temporarily unable to service your request due to maintenance
downtime or capacity problems. Please try again later.
Any ideas on what the problem is?


On Tue, Apr 24, 2018 at 3:51 AM Jonas Smedegaard <dr at jones.dk> wrote:

> Excerpts from Sunil Mohan Adapa's message of april 24, 2018 8:34 am:
> > I have had cases where I connect the power to my Lime2 and it does not
> > power on. When I disconnect and reconnect the power, it usually works.
> > I guess this might be due to a poor power supply or too many devices
> > connected via USB. I could be wrong.
> I have experienced same as above.
> > Also, I debug these cases by connecting a USB-serial connector. If
> > there are no boot messages related to u-boot on the serial console,
> > then it has to do with hardware but if the boot gets hung somewhere,
> > we can identify and fix the issue.
> >
> > I believe latest version of the Linux kernel also have HDMI out for
> > A20 SOCs. It is worth connecting Lime2's HDMI port to a monitor and
> > see what is happening.
> I believe updating kernel does *not* change what gets output to HDMI:
> Stable Debian linux packages support video putput to HDMI fine¹ and has
> not changed since then, but default software wiring² for LIME boards
> specifically has output to serial by default.
> For systems using flash-kernel, I believe the least involving tweak for
> redirecting U-boot output to HDMI is to add the following line close to
> the top of the file /etc/flash-kernel/bootscript/bootscr.sunxi:
>   setenv console tty1
> e.g. like this:
>   sed -i -r -e '2asetenv console tty1\n'
> /etc/flash-kernel/bootscript/bootscr.sunxi
> ...and then regenerate boot files, e.g. (indirectly) like this:
>   dpkg-reconfigure linux-image-...
> To tweak linux cmdline options, edit /etc/default/flash-kernel.
> Speaking of cmdline options, you might consider adding these to limit
> video buffers (freeing memory for general use):
>   LINUX_KERNEL_CMDLINE_DEFAULTS="sunxi_ve_mem_reserve=0
> sunxi_g2d_mem_reserve=0 sunxi_fb_mem_reserve=16"
> More info at https://linux-sunxi.org/Kernel_arguments
>  - Jonas
> ¹ Recent kernels improves on other HDMI signalling than video (e.g.
> audio) which is unrelated to the issue of getting console messages.
> ² setup of Device Tree (dtb) files built from U-boot and Linux.
> --
>  * Jonas Smedegaard - idealist & Internet-arkitekt
>  * Tlf.: +45 40843136  Website: http://dr.jones.dk/
>  [x] quote me freely  [ ] ask before reusing  [ ] keep private
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/freedombox-discuss/attachments/20180426/b4a14823/attachment.html>

More information about the Freedombox-discuss mailing list