[Freedombox-discuss] Unmet dependencies, "Applying updates failed".

A. F. Cano afc54 at comcast.net
Thu Dec 17 20:02:26 GMT 2020

On Tue, Dec 15, 2020 at 09:50:50PM -0500, James Valleroy via Freedombox-discuss wrote:
> On 12/14/20 6:00 PM, A. F. Cano wrote:
> > But the problem after all these packages got installed is that  there
> > are still unmet dependencies.  From cockpit->software updates:
> > 
> > The following packages have unmet dependencies:
> >   php-common: Breaks: php7.3-common but 7.3.15-3 is to be installed
> >   libgc1: Conflicts: libgc1c2 but 1:7.6.4-0.4 is to be installed
> >   fuse3: Breaks: fuse
> >   libgcc1: Depends: gcc-10-base (= 10.1.0-1) but 10.2.0-19 is to be installed
> >   python3-django: Breaks: python-django-common
> >   libmailutils5: Depends: mailutils-common (= 1:3.5-3) but 1:3.10-3 is to be installed
> >   libgc1c2: Conflicts: libgc1 but 1:8.0.4-3 is to be installed
> > 
> > What is the proper way to deal with this?  I've tried to keep the
> > FreedomBox completely standard, not installing anything manually.
> > Could this be related to backports?
> This issue is common on testing/bullseye (until it is frozen for release).
> The manual solution is to try upgrading just one of the listed packages
> (with "apt install <package>"), and see if that would lead to any important
> packages (freedombox, apps) being removed. If it would remove an important
> package, then you can cancel the upgrade. It may remove some non-important
> or obsolete packages, such as python2 packages, and that is ok.

Thank you.  Did that, one by one, and now everything is up to date.  Like
you said, some old packages got removed, I had to autoremove others but
no problem.

> --
> James


More information about the Freedombox-discuss mailing list