[Freedombox-discuss] Gobby stopped working.

A. F. Cano afc54 at comcast.net
Thu Dec 1 02:55:28 GMT 2022

Something must have changed in the last week or so.  Gobby (on Debian stable,
up-to-date) used to work great.  Now I can't connect to the server on the

When starting it now, the icons on the "Document Browser" window all have
little red "x"s on the lower right.  When double-clicking on the FreedomBox
address, I get a red "do not enter" sign and don't see the list of documents
I used to see.

To the right of the server name I see: "The server certificate is not trusted,
The certificate has expired."  Nothing has changed on the FreedomBox, except
for the regular updates that didn't include the gobby server, I think.  The
certificate for the domain is valid, enabled and expires on Feb 28 of 2023.
Even so, I re-obtained it, rebooted (multiple times) and it didn't make any
difference.  Maybe the re-obtaining it did nothing, the date of
expiration is still the same.

>From the gobby client: Preferences -> Security, I created new private key
and certificate.  Didn't make any difference.  Also selected "Authentication:
None, and tried again.  No difference.  Restarted gobby.  No difference.
Is the FreedomBox not allowing connections with "Authentication: None"?

The "Trusted Certificate Authorities" had the "Trust this computer's default
CAs" selected, as it always has been.  The "Additional Trusted CAs" had
"None" in the field, but I clicked on it and then I had to select a file.  I
selected cert.pem from ~/.config/gobby.  It is now impossible to restore this
field to None/blank.  The "Secure Connection" field has "Use TLS if
possible", as it had when it was working.

2 other people connect to this Freedombox.  One uses a very old gobby (for
Windows), version and can still connect fine, after a pop-up that
says "the connection is not secure, continue anyway?" or something like that.
This person has a very old certificate, obviouly not valid, and thus the pop
up warning.  The other uses the same (latest) version 0.6.0 (for windows)
and has the same problem I have.  I tried connecting from another computer,
same Debian stable, same gobby 0.6.0, and had the same problem.

It appears that the gobby client has been stable since the 0.6 release
(January 31, 2021, as seen here: https://github.com/gobby/gobby.  The
most recent issue is from April 27, 2022.  I don't see anything similar to
what I'm seeing.  Has the FreedomBox become more strict about security and/or
certificates in the last few days?

Has anyone else seen this behavior?  What can I try to figure this out?
All the self-tests pass on the FreedomBox.  Any specific debuging info
that would be helpful in tracking this down?

Thanks for any help or hints.  I really depend on the gobby server and client.
If I can't meke it work again, is there another collaborative editor similar
to gobby I could use?


More information about the Freedombox-discuss mailing list