[Freedombox-discuss] Any FreedomBox app that can do video conferencing, beside matrix?

A. F. Cano afc54 at comcast.net
Sat Jan 15 04:01:04 GMT 2022

On Fri, Jan 14, 2022 at 11:37:13PM +0100, Jonas Smedegaard wrote:
> Quoting A. F. Cano (2022-01-14 23:18:26)
> > I had been using matrix-synapse with the Element-desktop client for 
> > quite a while and I really depend on it.
> Element-desktop is essentially element-web copied into your system and 
> presented using a fork of the Chromium web browser called Electron.
> An alternative is therefore to simply use your favorite web browser and 
> Element-web, here: https://app.element.io/

Ok, I tried this.  The first thing I noticed is that it goes through
app.element.io even after I tell to go to my private server.  I'd rather
keep the data within my local network.  That was the purpose of
installing my own private server in my FreedomBox.  This is the
resulting URL:


Then, after I connected, supposedly to my own server on the FreedomBox,
which is local, so why go out to the internet?  I got the same problem
I got with Element-desktop.  The browser claimed I needed to give access
to my camera.  This is what the browser said:

The meeting needs to use your microphone and camera.  Select Allow when
your browser asks for permissions.

But the browser (konqueror) never does.  After a while, it goes to the
pre-meeting screen.  Clicking on the slashed camera icon and microphone
slashed icon does not work.

In this case when clicking on the "Join Meeting" button it does
get me into the meeting, as opposed to Element-desktop where this
doesn't work, but I still can't enable the video and microphone.

WIth firefox, it works eventually, but I need to give permission to:


and I'd rather not have all those interlopers.  Yes, ...freedombox.rocks
is my own Freedombox, so that one is ok, but all the others have no
business having to be enabled. Thank you NoScript!

The issue report I filed is here:


It contains the details of what I tried and what doesn't work with
Element-desktop.  To summarize here: I can never get into the meeting
via the "Join Meeting" button, but I can enable the camera and
microphone from the "pre-meeting" screen.  I also get disconnected every
30 seconds.

> Element-desktop is unlikely to be packaged for Debian officially, due to 
> Electron being too big a monster to build (already Firefox and Chromium 
> are monsters to build as well in Debian).

Mmm... Ok.  Still, I wonder if the problems I'm encoutering are both in
Element-desktop and element-web, at least on some brosers ie:
konqueror, or are they triggered by the server?  It shouldn't be
necessary to go to vector.im, riot.im, matrix.org and element.io to
contact my local FreedomBox.

In any case, thanks for replying.


More information about the Freedombox-discuss mailing list