[Freedombox-discuss] What a scare! Tried to brige internal interfaces, FreedomBox unreachable!

A. F. Cano afc54 at comcast.net
Sun Jan 30 23:08:52 GMT 2022


I've been wanting to do ssh and sftp between machines on my 2 internal
networks, but the machines on one network are not reachable from the
other and viceversa.  Tried ssh and sftp.  The only way to do ssh is by
ssh to the FreedomBox and from there to the machine on the other
network.  I have an apuid4 with 2 internal interfaces.

I noticed that "advanced options, such as bridging" can be done from
cockpit, says the networking page.  So I go to cockpit -> Networking and
I see a very convenient button: "Add bridge", I click on it and I see a
very nice, simple pop up with my 3 interfaces.  I select the 2 internal
ones and the interface freezes.  From that point on, the FreedomBox was
totally unreachable.  Not by web interface, not by ssh, not by ping.

The only thing I could do was to unplug it, take out the SD card, insert
it in the computer I'm writing this from and start researching what went
wrong.  I noticed that there was a file in
/etc/NetworkManager/system-connectins called bridge-somehing or other.
I removed it but that didn't help.  The other 2 files for the internal
interfaces: 'FreedomBox LAN enp2s0' and 'FreedomBox LAN enp3s0' Had been
modified with some lines with "bridge" on them, that I promply removed
but I had to restore all the lines that had been taken out that
contained the static (shared) IP addresses of the 2 internal netwroks.

Once that was done, and once the SD card was put back in, the FreedomBox
was back to normal. Whew!

Is bridging in this way not compatible with shared interfaces,
especially if the IP addresses are static?

I've had major trouble with bridging on other occasions (not on the
FreedomBox but trying to bridge a wifi interface on an internal machine
with hostapd), so there's likely something basic I'm not grasping, But
what a scare that was.

Any idea what happened?  Is this normal and expected behavior?

Is there some other type of firewall add-on that can be done to open
some ports in a limited way between the internal interfaces?



More information about the Freedombox-discuss mailing list