[Freedombox-discuss] Backups stopped working. Where are the logs? How do I debug this?

Sunil Mohan Adapa sunil at medhas.org
Thu Oct 19 00:35:30 BST 2023

On 10/15/23 11:55, A. F. Cano wrote:
>> https://github.com/borgbackup/borg/issues/4631
> Lots of possible solutions that people tried that ended up
> not working in this report.
> Any other ideas, anyone?

You attempts seemed to have worked. You ran into another problem that 
was fixed recently and will be available in next release. To workaround 
the problem right away, run the following command:

# borg info /media/{id}/FreedomBoxBackups
Warning: Attempting to access a previously unknown unencrypted repository!
Do you want to continue? [yN]

Answer 'y' above. The command will succeed. Repeating the command does 
not show the warning anymore. FreedomBox will now show the contents of 
the repository properly and scheduled backups will work.

By the way, I was able to reproduce the problem when I replaced the 
backup repository with an older copy. With this, I was able to find a 
workaround to the problem that works reliably. I am writing the solution 
here for future reference.

I ran the following commands

# rm -rf /root/.cache/borg
# rm -rf /root/.config/borg/security/{repo_id}/manifest-timestamp

{repo-id} for the troublesome repository needs to be found through a 
process of elimination. Look at the IDs in /root/.config/borg/security/. 
Run 'borg info {repo_path}' to known the ID of a working repository such 
as /var/lib/freedombox/borgbackup/. Eliminate the working IDs from the 
list and remaining one is the ID of the non-working repository.

This is sufficient if the repository is encrypted. However, if the 
repository is unencrypted the workaround involving 'borg info' command 
above (or the next version of FreedomBox are needed).

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_0x36C361440C9BC971.asc
Type: application/pgp-keys
Size: 41606 bytes
Desc: OpenPGP public key
URL: <http://alioth-lists.debian.net/pipermail/freedombox-discuss/attachments/20231018/5b294d12/attachment-0001.key>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://alioth-lists.debian.net/pipermail/freedombox-discuss/attachments/20231018/5b294d12/attachment-0001.sig>

More information about the Freedombox-discuss mailing list