[Fusioninventory-user] Working with SNMP...

Guillaume Rousse guillomovitch at gmail.com
Fri Oct 24 12:30:37 UTC 2014

Le 23/10/2014 17:40, Marco Gaiarin a écrit :
> Cleaned a bit my environment, i want to do some serious work with
> network discovery and SNMP.
> But still i'm frustrated on that, because i was not able to make it
> work, and, worst, i was not able to understand how it work.
> Base system: GLPI 0.84.7, FI 1: on debian wheezy.
2.3.9 is obsolete, current version is 2.3.12. Given the amount of 
changes in this part of the code, you should really update.

> For now, i've understood that:
> 1) i can setup an 'inventory task' on GLPI that can be binded to a
>   particular agent instance/host, and that run the discovery against the
> network.
> The same result is achived running 'fusioninventory-netdiscovery', eg
> running the task against one of my switches:
>   root at lupus:~# fusioninventory-netdiscovery --verbose --first --last
> and this is good, also seems to work on GLPI (eg, on my device i've
> some ''fusioninventory data''). Perfectly.
The purpose of a discovery task is to discover what's on your network. 
If you already know, you may as well creates the GLPI entry manually, 
and skip this step.

> 2) after that, you can bind another task, the 'netinventory' one, that
>   scan all the SNMP data and import it in GLPI, the ''static'' one
> (number of ports, ...) and the dynamic one (MAC address connected,
> counters, ...).
> Again this task can be schaduled, also binding it to a particular
> agent/host, but also run manually with 'fusioninventory-netinventory'.
> But this seems not to work. If i run:
> 	fusioninventory-netinventory --verbose --host
> i get rougly the same data of the previous 'netdiscovery' task,
> while if i run a snmpwalk i get:
> 	snmpwalk -Os -c public -v 1 > /tmp/ttt
> 	root at lupus:~# wc -l /tmp/ttt
> 	32886 /tmp/ttt
> What i'm missing?! Thanks.
I think you're affected with a bug I just found yesterday, affecting 
SNMPv1 multiple-values queries. You can easily workaround the issue with 
SNMPv2, ie:
fusioninventory-netinventory --verbose --credentials 
version:2c,community:public --host

As an alternative, use git version, or appply this patch:

More information about the Fusioninventory-user mailing list