[Nut-upsdev] megatec over USB - using Andrey Lelikov's approach

Peter Selinger selinger at mathstat.dal.ca
Sun Dec 31 20:55:10 CET 2006

Arjen de Korte wrote:
> Alexander I. Gordeev wrote:
> > Well, thank you for comments! If I understand right I should modify
> > Andrey's megatec_usb.c API to conform to one defined in serial.h and
> > then at link time select over serial.o and serial_usb.o (or usb.o)?
> I would prefer to name this serial_usb.o, since it is basically a serial
> protocol over an USB interface.

I would not give it quite as generic a name as serial_usb.o, because
it only implements one of several proprietary serial-over-USB
methods. We might support others in the future. How about a naming
scheme such as serial_usb_xxx.o, where xxx is some descriptor for the
particular method used. 

-- Peter

More information about the Nut-upsdev mailing list