[Nut-upsdev] Driver for Powercom BNT/KIN/IMP/IMD series

Alexey Sidorov alex at reutman.ru
Sat Dec 29 08:56:54 UTC 2007

Charles Lepple пишет:
> On Dec 24, 2007 9:04 AM, Alexey Sidorov <alex at reutman.ru> wrote:
>> Only for BNT/KIN/IMP/IMD:
>> power and linevoltage whould detect automatically now
>> also you don't need any other coefficients in ups.conf
>> added shutdown.stayoff and shutdown.return commands
>> start battery.test on driver start
>>  Tested on: BNT-1200AP
Tested on: BNT-1200AP, KIN-2200AP
> Since this has only been tested on one model so far, we should
> probably apply it to the SVN trunk first, and backport it to Testing
> (which is the branch where 2.2.0 and 2.2.1 came from) after it has
> been tested on some other models, or has been proven to be
> non-invasive.
This drivers not changed long time
My version must work with 2.2.0, 2.2.1, trunk :)
>> Example of ups.conf:
>> [<upsname>]
>> driver = powercom
>> port = /dev/ttyS0 # or which port you use
>> type = BNT          # or KIN or IMP (for IMP/IMD) or Trust or Egys or KP625AP,  your UPS model
>> Also, i think Trust and Egys - it's just KIN by another manufacturer, isn't it?
>> Also, KP625AP - what is it? What full name of this model?
> It looks like you are adding some possible values for the options -
> would you mind updating the documentation for the driver
> (man/powercom.8)?

> In a similar vein, it's a good idea to write up a summary of your
> changes in the same format as the ChangeLog file. This is what helps
> us collect the top-level changes that users need to know when they are
> upgrading NUT.
> Have you been in contact with the original author of this driver? If
> you are planning to make other changes to the driver, the simplest
> thing might be for you to check out a copy of the trunk from SVN, and
> send the output of "svn diff" (which is like the output of "diff -u")
> for easy identification of the changes.
I don't know who original author.
so many changes that I think make it easier to replace source files than patch them

> It looks like you changed the name of the nut_shutdown() function back
> to "shutdown". The nut_shutdown() name is intentional - there is a C
> library function called shutdown() that is used for sockets.
I don't quite understand

> We have convenience functions for setting the flow control pins now:
> http://boxster.ghz.cc/projects/nut/changeset/981 . You might be able
> to apply that patch (see "Unified diff" link at the bottom of that
> page) with a large fuzz factor to your copy of the code, but using SVN
> would probably be easier.

Best regards,	Alexey Sidorov
 	mailto:alex at reutman.ru
	JID: alex at reutman.ru
	ICQ: 5052225

More information about the Nut-upsdev mailing list