[Nut-upsdev] [nut-commits] svn commit r1204 - in trunk: . drivers

Carlos Rodrigues carlos.efr at mail.telepac.pt
Sat Dec 29 22:12:54 UTC 2007

On Dec 29, 2007 9:44 PM, Arjen de Korte <nut+devel at de-korte.org> wrote:
> If the specification says 'input frequency', that's what it is. If some
> vendors don't follow this, that's their problem. In any case I'm very
> much against breaking the NUT variable naming convention for something
> like this.

According to "new-drivers.txt", I'm not breaking the variable
convention at all. And it was after reading that part of the
documentation that I thought this might make sense instead of keep
providing a variable with dubious/false meaning.

The problem with the specs, is that the only ones available seem to be
from specific vendors, so there isn't actually a "right" or "wrong".
There is no standard (see the problem with some models having the OFF
flag enabled).

> If this really is a consern (which I very much doubt), I suggest to
> either drop this variable completely or reverse this change and put a
> note in the man page that some devices don't follow the specification here.

Dropping this variable is not very nice, since the frequency is a very
good indicator of power quality. And there's something more to this
than a reverse of meaning from some vendors. My UPS (a standby model)
seems to be showing input frequency while there is line power, but
then it keeps showing a value even on battery. If you think about it,
it actually makes (some) sense. While on line power this is the
frequency directly from the input, but while on battery it is the
output frequency from the inverter. Ratings information also avoids
defining nominal frequency and voltage as either input or output.

Again, I'd like to hear from whomever wrote that bit in
new-drivers.txt what the intention was. If I'm interpreting it wrong,
I'll do the appropriate changes, no problems whatsoever.

Carlos Rodrigues

More information about the Nut-upsdev mailing list