[Nut-upsdev] Driver for Powercom BNT/KIN/IMP/IMD series
clepple at gmail.com
Tue Jan 22 13:56:55 UTC 2008
On Dec 29, 2007 3:56 AM, Alexey Sidorov <alex at reutman.ru> wrote:
> Charles Lepple пишет:
> > It looks like you changed the name of the nut_shutdown() function back
> > to "shutdown". The nut_shutdown() name is intentional - there is a C
> > library function called shutdown() that is used for sockets.
> I don't quite understand
The function should not be called just "shutdown", since there is
already a function called "shutdown" in the C library. (It may work on
your computer, but it would cause problems down the road if someone
wanted to use the C library function.) That is why it is recommended
to add something to the name, like "nut_" - hence "nut_shutdown".
> > We have convenience functions for setting the flow control pins now:
> > http://boxster.ghz.cc/projects/nut/changeset/981 . You might be able
> > to apply that patch (see "Unified diff" link at the bottom of that
> > page) with a large fuzz factor to your copy of the code, but using SVN
> > would probably be easier.
- Charles Lepple
More information about the Nut-upsdev