[Nut-upsdev] Eaton_SDK dangling branch solved

Eric S. Raymond esr at thyrsus.com
Wed Jan 4 17:24:12 UTC 2012

I've solved the problem of the detached Eaton_SDK branch.

What must have happened here is the branch creator did a
non-Subversion cp -r followed by an add of the target directory.
This registered a tree that duplicated trunk, *without* ancestry
information connecting it to its source revision.

The correct fix is to check each new text section against a list of
MD5 hashes of old text sections.  If I find a match, I then fill in
copyfrom_path and copyfrom_rev information so it looks (for purposes
of parent and branch computation) as though the branch creation had
been done with "svn copy".

It is a very good thing that I found this before I shipped 2.0.

rst.old remains detached, so there is still another corner case for me
to nail down.

2.0-pre5 and auxiliary files have been uploaded to


The fix for the "fossil write" bug is in this version.  Also note that
metadata modifications through mailbox_in can now match by Fossil-ID
if Event-Number is absent.
		<a href="http://www.catb.org/~esr/">Eric S. Raymond</a>

Where rights secured by the Constitution are involved, there can be no
rule making or legislation which would abrogate them.
        -- Miranda vs. Arizona, 384 US 436 p. 491

More information about the Nut-upsdev mailing list