[Nut-upsdev] renaming (was Re: [nut] High level C and C++ libnutclient (#2))

Charles Lepple clepple at gmail.com
Wed Sep 5 22:57:13 UTC 2012

On Sep 5, 2012, at 6:08 PM, Arnaud Quette wrote:

>> There are also some references to "NUTD", which I think means "upsd".
> on my request, maybe too much anticipating 2.8 / 3.0...
> the name lib*nut*client  is also part of the naming evolution.

I've mentioned this before, maybe not on the list: I personally think that renaming the existing binaries and variable names is silly.

Are we planning on renaming "NUT" because the "U" stands for UPS? If someone with a power device other than an UPS finds the project, they should be able to handle the existing names. In the mean time, we would be making it more confusing for existing users who might have older installations with upsd, and newer installations with nutd.

libnutclient vs. libupsclient makes a little more sense, given that it's a completely different interface, but the new name doesn't really reflect the higher-level API.

More information about the Nut-upsdev mailing list