[Nut-upsdev] usbhid-ups on OmniOS (Solaris 10 derivate)

Arnaud Quette arnaud.quette at gmail.com
Fri Dec 19 12:00:58 UTC 2014

Hi Matej,

I've cc'ed the developers mailing list for now...

thanks for your report. Could you please send in some driver debug traces
(starting it manually, using "usbhid-ups -DDDDD ...")?
That would help in troubleshooting the issue.

thx and cheers,

2014-12-19 8:48 GMT+01:00 Matej Sekoranja <matej.sekoranja at gmail.com>:
> Update: driver is not stable. I am switching to apcupsd-ups driver.
> Matej
> On 19 Dec 2014, at 01:21, Matej Sekoranja <matej.sekoranja at gmail.com>
> wrote:
> Hi,
> I’ve recently installed OmniOS (running virtualized in VmWare ESXi with
> USB pass-through) and I got myself used APC SUA750I with USB port.
> I’ve successfully installed NUT tools. All seemed to work fine…. however I
> got no change updates, e.g. if I disconnected AC there was no report about
> it via NUT.
> Status was locked on OL, battery charge on 100% and so on… sometimes a
> value got updated, but this was very rare occasion (status was always OL).
> System reboot helped to get recent values.
> I’ve tried apcupsd and it worked flawlessly.
> Then I wnt back to nut and I’ve noticed that interrupt processing is was
> disabled in NUT:
> #if 1 //ndef SUN_LIBUSB
> bool_t use_interrupt_pipe = TRUE;
> #else
> bool_t use_interrupt_pipe = FALSE;
> #endif
> A hack to a hack to enable it… fixed it. Now it works as it should.
> It seems that SUN (well, Oracle) has fixed/updated their implementation…
> and requires IRQ to be processed.
> Cheers,
> Matej
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsdev/attachments/20141219/768071ca/attachment.html>

More information about the Nut-upsdev mailing list