[Nut-upsdev] usbhid-ups on OmniOS (Solaris 10 derivate)

Matej Sekoranja matej.sekoranja at gmail.com
Sun Dec 21 07:13:51 UTC 2014


here is more info:

uname -a
SunOS nas 5.11 omnios-10b9c79 i86pc i386 i86pc

# pkg info libusb
          Name: system/library/usb/libusb
       Summary: Sun wrapper library for libusb
   Description: Sun wrapper library for libusb (0.1.8)
      Category: System/Libraries
         State: Installed
     Publisher: openindiana.org <http://openindiana.org/>
       Version: 0.5.11
 Build Release: 5.11
Packaging Date: Tue Mar  5 14:15:49 2013
          Size: 111.13 kB
          FMRI: pkg://openindiana.org/system/library/usb/libusb@0.5.11,5.11- <pkg://openindiana.org/system/library/usb/libusb@0.5.11,5.11->

I’ve also attach a debug info. Note how input voltage switches deom 240 -> 0 and back to 240 after a while (I’ve switched of AC), however “AC present” status stays always 1.


> On 19 Dec 2014, at 14:23, Charles Lepple <clepple at gmail.com> wrote:
> Arno,
> what version of Solaris or libusb required the interrupt pipe hack?
> - Charles
> On Dec 19, 2014, at 7:00 AM, Arnaud Quette <arnaud.quette at gmail.com <mailto:arnaud.quette at gmail.com>> wrote:
>> Hi Matej,
>> I've cc'ed the developers mailing list for now...
>> thanks for your report. Could you please send in some driver debug traces (starting it manually, using "usbhid-ups -DDDDD ...")?
>> That would help in troubleshooting the issue.
>> thx and cheers,
>> Arno
>> 2014-12-19 8:48 GMT+01:00 Matej Sekoranja <matej.sekoranja at gmail.com <mailto:matej.sekoranja at gmail.com>>:
>> Update: driver is not stable. I am switching to apcupsd-ups driver.
>> Matej
>>> On 19 Dec 2014, at 01:21, Matej Sekoranja <matej.sekoranja at gmail.com <mailto:matej.sekoranja at gmail.com>> wrote:
>>> Hi,
>>> I’ve recently installed OmniOS (running virtualized in VmWare ESXi with USB pass-through) and I got myself used APC SUA750I with USB port.
>>> I’ve successfully installed NUT tools. All seemed to work fine…. however I got no change updates, e.g. if I disconnected AC there was no report about it via NUT.
>>> Status was locked on OL, battery charge on 100% and so on… sometimes a value got updated, but this was very rare occasion (status was always OL).
>>> System reboot helped to get recent values.
>>> I’ve tried apcupsd and it worked flawlessly.
>>> Then I wnt back to nut and I’ve noticed that interrupt processing is was disabled in NUT:
>>> #if 1 //ndef SUN_LIBUSB
>>> bool_t use_interrupt_pipe = TRUE;
>>> #else
>>> bool_t use_interrupt_pipe = FALSE;
>>> #endif
>>> A hack to a hack to enable it… fixed it. Now it works as it should.
>>> It seems that SUN (well, Oracle) has fixed/updated their implementation… and requires IRQ to be processed.
>>> Cheers,
>>> Matej
>> _______________________________________________
>> Nut-upsdev mailing list
>> Nut-upsdev at lists.alioth.debian.org <mailto:Nut-upsdev at lists.alioth.debian.org>
>> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/nut-upsdev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsdev/attachments/20141221/0b398b6a/attachment-0002.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: apc_usb_on_batt_test.tar.gz
Type: application/x-gzip
Size: 21336 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/nut-upsdev/attachments/20141221/0b398b6a/attachment-0001.bin>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsdev/attachments/20141221/0b398b6a/attachment-0003.html>

More information about the Nut-upsdev mailing list