[Nut-upsdev] RS-232 Port with Nut

Gernot Zander debian at scorpio.in-berlin.de
Tue Dec 1 17:04:57 UTC 2015


am  1 Dez schrieb Kjell Claesson:
>> [testups]
>> 	Driver = usbhid-ups
>> 	Port = /dev/ttyUSB0
> You need to change the driver to mge-shut (hid over serial).

Just for fun/good-to-know I tried my Eaton 5SC with different
connections today:
- UPS's USB-Port
   - driver usbhid-ups - startup time 5.2 seconds.
- UPS's serial port, real ttyS0
   - driver mge-shut - 19.7 seconds.
- UPS's serial port, real ttyS0
   - driver newmge-shut - 21.1 seconds.
- UPS's serial port, prolific 2303 serial converter, ttyUSB2
   - driver newmge-shut or mge-shut - "Unable to get HID Descriptor" or
     "No communication with UPS"

Seems the Eatons won't work behind serial USB adaptors.
I found almost the same with two different "Yunto-Q":
- The older model with serial port only workes both with pl2303 serial
  converter and at a real serial port (driver blazer_ser).
- The newer model, coming with USB and serial port, doesn't work like
  the Eaton with a USB serial adaptor (same pl2303), works at a real
  serial port only, driver blazer_ser (or using the UPS's USB port, of
  course, driver blazer_usb).
Some time ago I tried other serial USB adaptors (CP2102 and Moship),
both didn't work at all because they lack IRQ driven handshake lines
resp. the handshake lines at all. Maybe the FTDI chip is a little bit
better than the prolific, but I can't give one a test 'cause I don't
have one available for testing.

So I believe UPS do weird things at the serial port lines, so that
adaptors hardly (but only sometimes) work.

For the OP: Connect the UPS via USB-USB without adaptor or use a real
serial port, if you've still got one at your computer.


More information about the Nut-upsdev mailing list