<br><br><div class="gmail_quote">2012/11/28 Nicu Pavel <span dir="ltr"><<a href="mailto:npavel@mini-box.com" target="_blank">npavel@mini-box.com</a>></span><br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Hi,</blockquote><div><br>Hi<br><br>thanks for your patches. <br>though I've started to process your 1rst patch 6 days ago, my current latency should push me in acknowledging first...<br>note that I've discarded your 2nd patch, since the issue was already well addressed.<br>
<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div></div><div>A small update to the patch with correct names for upower-hid.rules and a running dump for openups.</div>
</blockquote><div><br>I committed your 1rst patch, with some changes (r<a href="http://trac.networkupstools.org/projects/nut/changeset/3791">3791</a>):<br><br>- I've bumped usbhid-ups version to 0.38<br><br>- I've moved openups-hid.h include into the ifndef SHUT_MODE in usbhid-ups.h<br>
<br>- I've fixed "upower, udev & friends" issue the right way:<br>mfr name has to be a comment on the line preceding the #define MFR_VENDORID 0x????<br>You've probably trimmed it since it was "OpenUPS" (maybe a different case) instead of Minibox.<br>
<br>- I've commented the "battery.cell<n>.voltage" variables.<br>As stated in docs/nut-names.txt (aka "NUT command and variable naming scheme"):<br>"If you need a new variable or command name, contact the Development Team first."<br>
This will need a dedicated discussion, still on -upsdev<br><br>- I've moved "therm_tbl & size" from openups-hid.h to .c<br><br>- BTW, there are some non-compliance such as with Usage IDs for "Cell?" (0x0000000?):<br>
as per the <a href="http://www.usb.org/developers/devclass_docs/pdcv10.pdf">HID/PDC spec</a>, ยง 4: <br>"Usage pages xFF00 to xFFFF are reserved by HID for vendor-specific implementation."<br><br>- battery.capacity is in Ah!<br>
and you'll have to actually fill in your (FW) string descriptor ;)<br clear="all"></div></div><br>cheers,<br>Arnaud<br>-- <br>NUT (Network UPS Tools) Project Leader - <a href="http://www.networkupstools.org" target="_blank">http://www.networkupstools.org</a><br>
Debian Developer - <a href="http://www.debian.org" target="_blank">http://www.debian.org</a><br>Free Software Developer - <a href="http://arnaud.quette.fr" target="_blank">http://arnaud.quette.fr</a><br><br>