<div dir="ltr"><div>Hi Dan and Charles<br><div class="gmail_extra"><br></div><div class="gmail_extra">Dan, thanks again for all your hard work on NUT.<br></div>I really much appreciated that you satisfied all my previous comments!<br>
</div>I know how hard it is ;)<br><div><div class="gmail_extra"><br><div class="gmail_quote">2013/11/6 <a href="mailto:hyouko@gmail.com">hyouko@gmail.com</a> <span dir="ltr"><<a href="mailto:hyouko@gmail.com" target="_blank">hyouko@gmail.com</a>></span><br>
<blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">In my opinion, there might be just one problem: the blzr driver<br>
doesn't provide anymore two splitted drivers (serial and usb), so this<br>
isn't going to be a 'silent update' for those using these drivers<br>
(should we provide symlinks or the like?).<br>
If this doesn't sound like a problem to you, I'll take care of the rename.<br></blockquote><div><br></div><div>ah, good point! I completely missed that.<br><br></div>I must admit that I wasn't too thrilled at first by this merge.<br>
</div><div class="gmail_quote">however, considering the specific nature of the Q* family (and I can tell that we've just seen the emerged part of the iceberg!), and the upcoming transition, it makes sense!<br></div><div class="gmail_quote">
the code overhead is low, and most if not all recent Q units come with USB only (hence, the serial support overhead is ever lower)<br></div><div class="gmail_quote">however (again), considering the overall changes in the driver approach, we can't force the usual transition!<br>
we really need to collect a minimum feedback, with enough coverage, before forcing the switch.<br><br>there remains only one option:<br>- keep blazer_ser and _usb,<br>- rename blzr to "blazer"<br></div><div class="gmail_quote">
=> will collide on the manpage!<br></div><div class="gmail_quote"> => I would prefer "nutdrv_qx", to initiate a new driver naming effort<br></div><div class="gmail_quote">- suggest user to transition and report on "blazer" ("nutdrv_qx").<br>
</div><div class="gmail_quote"> => double HCL entries is the best way to advertise (i.e. "blazer or blazer_{ser,usb}"), along with UPGRADING<br></div><div class="gmail_quote"> => call to user tests on the list<br>
</div><div class="gmail_quote"><br></div><div class="gmail_quote">this last point brings another one:<br>why do you specify the voltronic protocol in HCL entries? (i.e. "blzr protocol=voltronic")<br></div><div class="gmail_quote">
as the default, you shouldn't need so!<br></div><div class="gmail_quote">or did I miss something?<br><br></div><div class="gmail_quote">Thanks and cheers,<br>Arno<br><div><br></div></div></div></div></div>