[Nut-upsuser] Sustainer S-1000C (Powercom protocol)

Dror Eiger dror_eiger at hotmail.com
Fri Aug 19 12:27:05 UTC 2005


I've sent the following message 3 weeks ago, yet have recieved no reply at 
all. I don't want to nag, but could anyone please help me?



I have a UPS of the Israeli company Sustainer, model S-1000C 
(http://www.sustainer.co.il/data/files/specifications%20smart%20en.pdf - 
don't worry, it's in english...).

I've been trying to connect to it from Debian to no avail for a long time 
The company has attached to it a program called Commander Pro (for windows) 
and RPMs of UPSmart for old versions of Redhat and Mandrake, which were of 
no use to me.
When I requested a program for Debian, they gave me "clientmate for linux" 
which is an old tarball installation that didn't work even after being 
adjusted manually.

In the end I've decided to try to download the drivers from another Israeli 
company, Advice, from the reasonable assumption that they probably use the 
same far-eastern manufacturer, and voila: it worked! The program is Powercom 
UPSMON Plus (http://www.advice.co.il/data/prog/UPSMON_LINUX.zip).
The program itself gave the following feedback:
# ./upsmon /dev/ttyS0 300 60
Copyright(c) Powercom Co., Ltd., all rights reserved.
UPSMON V0.9 program start!
UPSMON: The COM port use /dev/ttyS0.
UPSMON: Ac Fail count down is seted 300 secs.
UPSMON: UPS shutdown delay time is seted 1 mins and 0 secs.
Check UPS type.....
UPSMON: UPS Connected!!

And the enclosed upsdisp program gave the following nice screen:
UPSMON Plus For Linux V0.71
NOW:Fri Jul 29 23:30:22 2005 |
Power Loading 19.0% |
>>>>| AC Fail count: 300
| Input AC Power: AC Normal
Battery Capacity 100.0% |
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>| Battery Status: Normal
| Avr Status: Bypass
AC Input Voltage 197.0V | UPS Status: Normal
| Temp: 37.8°C
| Line Freq.: 49.9Hz
AC Output Voltage 232.0V |
>>>>>>>>>>>>>>>>>>>>>>>| Serial Port: /dev/ttyS0
| Comm. Status: Conn.

Press Ctrl_C to Exit UPSMON Plus Display Program!!

Nevertheless, I haven't managed to make NUT work with it. When I tried using 
the powercom driver, I got the following response, no matter which type I 
entered (including the KIN1500AP I've seen on the wayback machine had the 
same problem - 
# upsdrvctl start
Network UPS Tools - UPS driver controller 2.0.1
Network UPS Tools - PowerCom and similars protocol UPS driver $ Revision: 
0.5 $ (2.0.1)

data receiving error (-1 instead of 11 bytes)

Running the driver itself on KIN-1500AP with debug:
/lib/nut# ./powercom -D -x type=KIN1500AP /dev/ttyS0
Network UPS Tools - PowerCom and similars protocol UPS driver $ Revision: 
0.5 $ (2.0.1)

debug level is '1'
Values of arguments:
manufacturer : 'PowerCom'
model name : 'Unknown'
serial number : 'Unknown'
line voltage : '230'
type : 'KIN1500AP'
number of bytes from UPS: '16'
method of flow control : 'no_flow_control'
validation sequence: '{{7,0},{8,0},{8,0}}'
shutdown arguments: '{{0,10},n}'
frequency calculation coefficients: '{0.000210,0.000000}'
load percentage calculation coefficients: 
battery percentage calculation coefficients: 
voltage calculation coefficients: '{0.828570,0.000000}'
data receiving error (-1 instead of 16 bytes)
data receiving error (-1 instead of 16 bytes)
Signal 2: exiting

While UPSMON plus is up, doing cat on /dev/ttyS0 gives the following data:
(199.0 199.0 235.0 019 50.0 27.8 37.8 00101000^M

Any thoughts?

Thank you,

Don't just search. Find. Check out the new MSN Search! 

More information about the Nut-upsuser mailing list