[Nut-upsuser] cannnot load drivers for a Belkin F6C800-UNV

Drew drew.kay at gmail.com
Sat Nov 26 10:25:34 UTC 2005


I've been fighting with trying to get a Belkin Universal model
F6C800-UNV to work with NUT. The error I am getting is as follows:

 * Starting UPS drivers ...
Network UPS Tools - UPS driver controller 2.0.0
Network UPS Tools - Belkin 'Universal UPS' driver 0.06 (2.0.0)

tcgetattr(/dev/ups): Inappropriate ioctl for device
Driver failed to start (exit status=1)
 * Failed to start UPS drivers!

Steps I've tried:

I have tried adjusting my chmod settings on the usb entry in dev. This
is a udev based system.
yuna dev # ls -l
lrwxrwxrwx  1 root root 9 Nov 26 01:31 ups -> usbdev3.5
crwxrwxrwx  1 root root 189, 260 Nov 26 01:31 usbdev3.5
# Belkin UPS udev entry (creates /dev/ups)
BUS="usb", SYSFS{idProduct}=="0980", NAME="%k", SYMLINK="ups"

I have tried using all four drivers that are known to be compatible
with belkin units.

I have googled for similar problems with other USB based UPS units.

My rig is a nForce2 based AthlonXP running Gentoo w/ kernel 2.6.14.
dmesg shows nothing unusual. The output is after unpluging the USB
cable to get udev to add the new /dev/ups entry and trying to load the
ups driver. The unit's USB is working as Bulldog works fine under

cdrom: open failed.
usb 3-1.4: USB disconnect, address 4
usb 3-1.4: new low speed USB device using ohci_hcd and address 5
HID device not claimed by input or hiddev
usb 3-1.4: usbfs: process 18134 (lsusb) did not claim interface 0 before use
usb 3-1.4: usbfs: process 18188 (lsusb) did not claim interface 0 before use

If anyone can offer advice/suggestions/direction to tackle this one
I'd be very grateful.



More information about the Nut-upsuser mailing list