[Nut-upsuser] ownership of pid directory

Doug Reynolds mav at wastegate.net
Thu Dec 28 23:17:40 CET 2006

Arjen de Korte wrote:
>> The cpsups driver has some flow control issues...  my cyberpower 1200AVR
>> is kinda dumb.
> The cpsups driver is rightfully flagged 'experimental'. There has been no
> active maintenance on this driver for at least two years. We have tried to
> fix some obvious errors in it, but if we can't find a developer to iron
> out the remaining issues with it, it probably deserves to be flagged
> 'broken' instead.
After during some extreme testing of my CPS1200AVR, the trouble isn't 
100% with the driver.  The driver itself works the way it should.  I've 
found if you issue those UPS commands thru a serial port, the UPS acts 
the same (shuts down after a couple minutes).  The ups worked _great_ 
with the generic driver, but you don't get all those nifty, smart 
features).  The only difference I can figure out is that the Windows UPS 
driver holds one of the control pins high until it wants the UPS to shut 
down (I noticed this when I had the ups on my Windows machine and was 
monitoring the serial port).  At that time, I didn't really think it was 
important.  However, not being super knowledgeable with c/cpp (or the 
NUT format, for that matter), I haven't been able to do much 
experimentation with it.  I guess I'm going to have to subscribe to 

More information about the Nut-upsuser mailing list